Support » Plugin: Google XML Sitemaps » Google WebMaster tools flag an error of ‘noindex” for the html map

Viewing 15 replies - 16 through 30 (of 30 total)
  • disable “Include sitemap in HTML format” in settings XML-SITEMAP

    • This reply was modified 3 months, 1 week ago by  mertij.

    Yes! That works. Thanks @mertij

    That should be the default. I don’t think there is any need to even include that HTML page (maybe it already is the default I turned it on?!) Either that or the HTML page should not say “noindex”. Actually, if possible, if that flag is Enabled, then the HTML page should not say “noindex” and vice versa.

    Will try this @mertij, thnx!

    swissspaceboy

    (@swissspaceboy)

    Got same bug. The HTML is for search engines that do not support the xml format. Don’t know if this HTML format is still useful.
    The “noindex” is correct as the sitemap.html page must not be indexed, but followed of course.
    I propose not to include this sitemap.html file in the xml sitemaps anymore.

    under Basic Options, UNCHECK the box that says “Include sitemap in HTML format”

    Hi All –

    Just reading your suggestions as I, too, received this for one of my sites.

    I unchecked the box. Do I need to resubmit the sitemaps on google?

    Thank you!

    No resubmit required. It may take a few days for Google to update their message, though. But it will just happen.

    Alex

    Thank you!

    I have a proper solution recently I found.. And thats amazingly working.. No doubt it will not work.

    so watz d solution @gadgetsay ??

    Gadgetsay

    (@gadgetsay)

    Deleting the whole site! if hosted on VPS then just delete it from there.. or you can also do from shared hosting.

    I hope it helps everyone!

    egycode

    (@egycode)

    Try this a temporary fix,

    Just comment php code in this file google-sitemap-generator/sitemap-core.php

    Find this code line 1574

    		//Do not index the actual XML pages, only process them.
    		//This avoids that the XML sitemaps show up in the search results.
    		if(!headers_sent()) header('X-Robots-Tag: noindex', true, 200);

    Just comment out the last line by adding // before.

    And the other file xml code in this file sitemap.xsl

    Find this code

    Line 12:
    <meta name="robots" content="noindex,follow" />

    Comment it out like this

    <!--<meta name="robots" content="noindex,follow" />-->

    I’m waiting google response as they are validating my fix for the current issue and will update my post soon 🙂

    Thanks.

    • This reply was modified 2 months ago by  egycode.
    • This reply was modified 2 months ago by  egycode.
    cdgweb

    (@cdgweb)

    Changing the plugin should only be done by the developer.

    Alexis Wilke

    (@alexiswilke)

    @cdgweb It can help speed up a developer’s work if you change the code to test on your end and offer it to them in case it works. However, in this case, I don’t think it’s the correct behavior. They should instead look into not adding that page to the sitemap.xml (as others have done earlier.) I don’t personally see any value in having such a page in your sitemap.xml anyway. It’s not going to help your SEO.

    I noticed

    i was using “Google Sitemap Generator Plugin by Arne Brachhold”. It was not making all my posts site maps so i removed it and started using the yoast built in maps building tool. But now i even don’t have the plugin installed it still has “no-indexing” issues. Well, there should not be any problem because sitemaps are already indexed by google from yoast maps. But I am really concerned how do i completely turn off this feature that Google Sitemap Generator Plugin by Arne Brachhold plugin created.

    Solution:

    Then i went to my cPanel and under file manager, of the concerned website:
    Go to the website location:
    Go to WP Content
    Go to Plugins
    Select Google Site Maps
    and Delete it. Let it go to the trash.
    Now i don’t have any problem because not sitemap.html redirects me to yoast maps.
    Cheers

    • This reply was modified 2 weeks, 4 days ago by  veerubhinder.
Viewing 15 replies - 16 through 30 (of 30 total)
  • You must be logged in to reply to this topic.