WordPress.org

Support

Support » Plugins and Hacks » UpdraftPlus WordPress Backup Plugin » [Resolved] Google truncates redirect URI

[Resolved] Google truncates redirect URI

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author David Anderson

    @davidanderson

    Hi Chris,

    Someone else who had this issue said that the solution was to not use Google’s new beta console, but the traditional one instead. Were you using their new one?

    David

    Plugin Author David Anderson

    @davidanderson

    P.S. If it was the new one, then please have a look to see if there’s a way to report it to Google. It’ll be very bad news if they make the beta console into the one for everybody before they fix this – then we’ll all be in trouble!

    David

    Thanks for the quick response, David.

    I believe it was the new “Cloud Console”. I will (a) try to revert to the traditional, (b) report the issue to Google, and (c) try another remote service in the interim.

    Just curious – if Google goes forward with only allowing a single parameter, will you be able to make the plugin work with that, or might that constraint prevent us from using Google Drive?

    Chris

    Plugin Author David Anderson

    @davidanderson

    Hi Chris,

    Re-engineering to use only a single parameter wouldn’t be a problem; just somewhat annoying to have to spend the time on it! My Googling hasn’t turned up any information on this, so it’ll be interesting to hear if Google can tell you whether this is a bug or deliberate on their behalf.

    David

    I understand and I agree. I will let you know if I receive any response from them.

    Thanks again.

    Chris

    Plugin Author David Anderson

    @davidanderson

    Hi Chris,

    Thank you…

    I went to have a look at this myself, to see if I could add a screenshot to show people how to get out of the new Cloud Console. I couldn’t find a way – whenever I got to the old API console, it automagically redirected me to the new one.

    It then occurred to me that UD can drop one of the two parameters from its redirect_uri, and reconstruct it internally. i.e. A workaround. So, I’ve implemented that; it’s in the development version (which we plan to release next week): http://updraftplus.com/faqs/devversion/

    Best wishes,
    David

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Google truncates redirect URI’ is closed to new replies.
Skip to toolbar