Support » Plugin: Google Tag Manager for WordPress » Google Tag Manager & Avada Theme

  • Resolved digital-workshop

    (@digital-workshop)


    Hallo,

    leider verursacht das Plugin einen Fehler mit dem Avada Theme.

    Kommt eventuell ein Update?

    Avada Support schreibt dazu:
    Google Tag Manager plugin is causing some JS error, which in a result is breaking the functionality of other JS modules.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Thomas Geiger

    (@duracelltomi)

    Hi,

    Thanks for the question.
    May I ask you to communicate in English on this forum? It would be better for other forum visitors who try to find an existing answer around an issue.

    I’ve never received any bug report from Avada or any Avada user thus I am not aware of such an issue. Please describe your finding in more detail so that I can check it and provide a fix.

    Hello,

    the Avada Support send me this:

    Google Tag Manager plugin is causing some JS error, which in a result is breaking the functionality of other JS modules. Here is a screenshot for reference ->
    https://snag.gy/s61npV.jpg

    I have tried by switching to WordPress default theme and I could see the same error there too. Here is a screenshot for reference -> https://snag.gy/vUXaDj.jpg

    I believe either Google Tag Manager plugin is misconfigured or got a bug and hence this issue. So I’d recommend you to get in touch with their support about this. As they know their code better and can provide finer insight. You can contact them at below link

    https://wordpress.org/support/plugin/duracelltomi-google-tag-manager

    Plugin Author Thomas Geiger

    (@duracelltomi)

    Hi,

    “mixpanel” is not part of the plugin, my guess is that you included a mixpanel code in your GTM container that does not work properly. You should open the container GTM-MM8PZ6Z and check whether there are any mixpanel tags inside. If there are, you should pause them and publish a new container version.

    Yes, that’s true. We have forgotten the mixpanel library, which has to be put into the <head> part.

    Now it is placed there (sorry for the confusion), yet there are still errors like:

    Uncaught TypeError: jQuery(…).fusion_calculate_empty_column_height is not a function
    at fusionCalcColumnEqualHeights (274d7275ed26e6aa2989962c86e24910.js:89)
    at 274d7275ed26e6aa2989962c86e24910.js:89

    And these errors prohibit a lot of functionalities.

    Deactivation of the GTM plugin shows correct functionality without any JS errors.

    To us it seems that there are jquery libraries with different version numbers loaded by the WP-implementation when both Avadas Fusion builder and the GTM plugin are active.

    Plugin Author Thomas Geiger

    (@duracelltomi)

    This error message seems not to be related to my plugin too.

    Is it possible to share the URL of your website here?
    It is very hard to give you any idea using just small pieces of error messages.

    In your recent post the function fusion_calculate_empty_column_height() is part of the Avada theme, I am not sure how my plugin can break this without seeing the whole site first.

    What I can see is that you might using a cache plugin that merges every JavaScript code into one .js file. This is a common approach to speed up websites. My website is also using a cache plugin (WP Rocket) but I do not have any issues. My assumption is that the root of your issue will be around your cache plugin and something that might be not setup well.

    But without seeing your website, this is all I can suggest at this point.

    Plugin Author Thomas Geiger

    (@duracelltomi)

    FTR: finally it turned out that there was a malfunctioning script inside the GTM container itself.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Google Tag Manager & Avada Theme’ is closed to new replies.