Support » Plugins and Hacks » [Resolved] Google still recommend Javascript etc.

[Resolved] Google still recommend Javascript etc.

Viewing 1 replies (of 1 total)
  • Plugin Author bassjobsen


    Hi Serge,

    Thanks for your feedback.

    1) nice

    2) “Eliminate render-blocking JavaScript and CSS in above-the-fold content”. i don’t known if this is about javascript or CSS only. I think that many sites can profit from defer loading of CSS, it’s still an issue of the plugin: https://github.com/bassjobsen/wp-defer-loading/issues/3
    Finding the above-the-fold with a plugin won’t be easy. I think evaluating common used CSS frameworks will be the first step. For example Twitter’s Bootstrap has CSS for many plugins which are mostly under the fold. Also Glyphicons are, i think (about 10% of the code).
    Checking the CSS base for not used code should be the first step for everyone in this case. Also check for plugins you don’t use any more, etc. etc.

    3) is your most complex question. The plugin only works when all your plugins and theme enqueue their scripts well, i wrote a blog about it:http://bassjobsen.weblogs.fm/wordpress-development-properly-load-javascript-set-dependency/. If you find out which plugin in your case gives the trouble, i will try to fix it for you, if it has an open license or write the author. I expect in your site some kind of leanmodal plugin can be the reason.

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] Google still recommend Javascript etc.’ is closed to new replies.