Google Sitemaps and WordPress 2.3 (Please help testing) (87 posts)

  1. aaronfleischer
    Posted 8 years ago #

    Hi Guys...

    New in here....

    Hope i'm welcomed !

    When i'm trying to access my Sitemap it's reading...

    "Error loading stylesheet: A network error occured loading an XSLT stylesheet:"


    tried everything....checked the directory that sitemap.xml is referring to, there is no destination error and also the files are writable...

    Can anyone help me with this...

    I'm very poor at coding, your help would be really really appreciated.....

    Thanks !!!

  2. scottficek
    Posted 8 years ago #

    ****Update-Seems to be working****

    I re-enabled the plug-in and started playing with the settings. I first started by unchecking all the boxes and set the "Limit number of posts" to 25 and put the memory at 16M and timeout to 0. It ran. I gradually increased the post count to 150 and then to blank and it ran.

    I started re-checking the boxes and it kept working until I checked the "Write a gzipped file (your filename + .gz)". When I turn that one on (with all other settings back to default except memory 16M and timeout to 0) it locks up like before.

  3. archjedi
    Posted 8 years ago #


    Nice find! I immediately went to uncheck that (Write a gzipped file (your filename + .gz) and sure enough it built the sitemap.

    I tried checking it again and rebuilding the sitemap...got the blank screen.
    Unchecked..worked again.

    But, isn't the gz file more essential than having the non zipped .xml file?

  4. jerrywaxler
    Posted 8 years ago #

    <<<<<<<<Nice find! I immediately went to uncheck that (Write a gzipped file (your filename + .gz) and sure enough it built the sitemap.>>>>>>>>

    Ditto for me. I was having the hanging problem and I unchecked .gz and it works.

    Jerry Waxler

  5. VeraBass
    Posted 8 years ago #

    I installed the new version yesterday(?) with no difficulty - am still on 2.2.3. (awesome plugin)
    Creating the sitemap, writing in my robots.txt, etc. is working fine. Failed on Yahoo, and the link to see result gives me a blank page. Cannot edit manually as it refuses to save this option.

    It is also producing this error notice every time it writes:

    Notice: Undefined index: path in /wp-admin/admin-functions.php on line 1683

    this is the code it refers to:

    function get_home_path() {
    	$home = get_option( 'home' );
    	if ( $home != '' && $home != get_option( 'siteurl' ) ) {
    		$home_path = parse_url( $home );
    		$home_path = $home_path['path'];
    		$root = str_replace( $_SERVER["PHP_SELF"], '', $_SERVER["SCRIPT_FILENAME"] );
    		$home_path = trailingslashit( $root.$home_path );
    	} else {
    		$home_path = ABSPATH;
    	return $home_path;

    I just went in and changed the savequeries code, so I don't have any mysql reports yet.

    There also is no 'rewrite now' button. I saw that in 'read me' and looked for it so many times my eyes crossed. :)

    (I do plan to upgrade as soon as my total newness with php and mysql wears off a bit more)

  6. nielshoven
    Posted 8 years ago #

    I am experiencing the same problem - the plugin works perfectly if I uncheck the "write a gzipped" file option and hangs if I check it. My blog is not that large and I set up a php.ini file to increase the time and memory limits anyway, so I can't figure out what the problem is now.

    I don't know if this is significant, but when I click the debug function I get tons of notices that look something like:

    Notice: Undefined property: stdClass::$post_title in /home/neilhov3/public_html/wp-includes/post.php on line 440

    I also don't know if this is significant, but my database backup plugin, which creates a gzipped backup, has also recently stopped working.


  7. massagegeek
    Posted 8 years ago #

    I just upgraded to the newest version of this plug in and get this error message:

    WordPress database error: [Table 'julieono_wrdp1.wp_post2cat' doesn't exist]
    SELECT cat_ID AS ID, MAX(post_modified) AS last_mod FROM wp_posts p LEFT JOIN wp_post2cat pc ON p.ID = pc.post_id LEFT JOIN wp_categories c ON pc.category_id = c.cat_ID WHERE post_status = 'publish' GROUP BY cat_ID

    Warning: Cannot modify header information - headers already sent by (output started at /home/julieono/public_html/blog/wp-includes/wp-db.php:160) in /home/julieono/public_html/blog/wp-includes/pluggable.php on line 391

    Hope it can be worked out? I just installed the older version and still get this error message when deleting a post...

    WordPress database error: [Table 'massagep_wrdp1.wp_post2cat' doesn't exist]
    SELECT cat_ID AS ID, MAX(post_modified) AS last_mod FROM wp_posts p LEFT JOIN wp_post2cat pc ON p.ID = pc.post_id LEFT JOIN wp_categories c ON pc.category_id = c.cat_ID WHERE post_status = 'publish' GROUP BY cat_ID

    It still seems to work but should I still use it? Blogging without a google sitemap is like a fish with no water...

  8. jonathanryan
    Posted 8 years ago #

    I'm getting the same problem as FantasyCrusader and others....

    I upload the plugin, activate i and immediately get a server 500 error. I can't go into the plugins page to sort anything out. Delete the plugin via FTP and plugins page works again.

    I disabled all other plugins and it worked. renebaleed them one by one and got conflicts with the following plugins....
    1. Related posts (http://www.rene-ade.de/inhalte/wordpress-plugin-relatedposts.html)
    2. Samsarin
    3. WordPress.com stats 1.1.1

    Removing those made sitemap run OK.

    I'm on WP 2.3.2 and Google sitemaps 3.0.3

  9. jonathanryan
    Posted 8 years ago #

    Hmm - this is getting worse. A lot worse.

    Any plugin I upload now trashes the plugins page - it's just not accessible. Delete the plugin and you can get back in.

    This behaviour ONLY happens with Google Sitemap installed and stops happening if I delete it.

    Looks like a major conflict going on somewhere.

  10. jonisolis
    Posted 8 years ago #

    I am getting this error message on the page where my site map should be http://alove4horses.com/blog/sitemap.xml:

    Error loading stylesheet: A network error occured loading an XSLT stylesheet:http://alove4horses.com/blog/wp-content/plugins/sitemap.xsl

    I have WordPress 2.3.2 and just installed the XML Sitemap Generator for WordPress 3.0.3 plugin. So it still has bugs I guess. Is anyone getting it to work with WP 2.3.2? What is the work around?

  11. webdevguy2
    Posted 8 years ago #

    I follwed the instructions in the readme file and created the sitemap.xml and sitemap.xml.gaz files in the root directory and chmod to 666.

    I activated the plugin and it throws up a dialog box to open the plugins.php file:

    You have chosen to open"

    I can no longer access the plugins page and have to manually delete the google sitemap plugin directory to be able to access the plugins page again.

    I have clear cache and cookies in my browser.

    Any ideas?

  12. allonline
    Posted 8 years ago #


    With WP2.3.2 and the latest XML-Sitemap plugin i have it running ok and can manually build and also if i load the url given for using a GET command (as indicated by clicking on the ? as per instructions) in a browser address the sitemap updates, my problem is i would like to use this with a cron job in cPanel but i havent been albe to get it work.

    See this post for more info.

    domain is http://www.onyourpc.com
    sitemap is http://www.onyourpc.com/sitemap.xml

    tried using curl --silent <url given by plugin> >dev/null 2>&1 also but still no update. Get no errors as such just the code of my home page emailed to me showing the cron activated.

    Any one ever used this with a crom job, if so what command string did you use?



  13. Arne Brachhold
    Posted 8 years ago #

    @jonisolis: Looks like your server doesn't want to deliver the stylesheet which is used to make the sitemap more "human friendly". You can smply deactivate this feature at the plugin options page by removing the URL in the text field next to "Include a XSLT stylesheet".

    @webdevguy2: Maybe activating the plugin hits the PHP memory limit... You can try to raise it following the introductions from the last posts of the following thread: http://wordpress.org/support/topic/127914?replies=6

    @allonline: I think you're the first one who actually uses this feature ;-) I will check if it's still working...

  14. allonline
    Posted 8 years ago #

    Thanks Arnee, it all seems to be working fine manually and if i click on the little question mark to update via GET command and copy the url given into a browser address bar i get a blank page returned which is ok as when i check to see if its updated the sitemap it has. Its only when i try to run the same url via a cron job in cpanel i cant seem to get the command string correct.

    The cron job runs but i get emailed the code to the home page on the blog, when i log in to check if its updated the sitemap it has not. I have tried GET and then the URl, wpget, curl with and without silent command, directed reurned output to null etc but just cant seem to get it right, i used to run a similar process via cron before using curl and that worked ok, my host doesnt really have any restrictions that have prevented other jobs running in the past.

    I have no cron jobs running now that may clash on any blog i use sitemaps plugin on so it cant be that.

    I have this weekend upgraded all blogs to 2.3.3 and all plugins to the latest (all 5) all works fine with no clashes i can see. I would have thought someone else has this running via cron in the past as i would like to schedule it for evry couple of days just to make sure its rebuilt and the search engines are notified, i added a yahoo API key to every blog (all 6) this weekend so yahoo gets notified as well, i have no problems with timeouts etc as i have resticted building to just 500 urls and set a memory limit and background process options etc to avoid problems.

    If anyone has used cron for this plugin it would be nice to see samples of the command string to try. Cant understand why it work if loaded in a browser address bar but not via any cron job ive tried, didnt even get any errors reported from cron to give a clue like i would normally get while trying to figure out something like this.

    The only think i havent tried is running with a login ID and password in the command string as the instructions say it shouldnt need one.

    By combining this plugin with the Dagon Design php sitemap im getting spidered loads.


    Link in the footer



  15. akulavolk
    Posted 8 years ago #

    When I try to create a sitemap, I get a "There was a problem writing your sitemap file. Make sure the file exists and is writable."

    I followed the instructions for chmod on sitemap.xml and sitemap.xml.gz files. I've tried 666 and 777 but no dice. Hopefully this will help narrow down what's happening:

    - I CAN get creating a sitemap to work if I do a "rebuild site manually" to http://www.mysite.com/blog/sitemap.xml
    - However, this fails when I tell it to create the file at http://www.mysite.com/sitemap.xml. Of course, this is where I'd prefer for the sitemap to be located since I'll be indexing other files at a directory level higher than my blog.
    - When I write files to http://www.mysite.com/sitemap.xml, I get the error above and 0byte files (no updates from the blank files I placed there in the beginning).
    - If I copy the working .xml/.gz files from my /blog/ directory to the root of my site, I still get the error on manually creating the files. The creation/mod times and files sizes are NOT updated after this step, so it's not overwriting them.
    - I'm trying to use the "complete" URL option (http://www.mysite.com/sitemap.xml). Since my blog is a subdirectory of my main site, relative and auto detect won't work for me.

    Sounds to me like a permissions thing (obviously), but I've checked these files and they're writable (666 or 777). Is there some other permissions issues I should be aware of, or any recommendations for fixing this?


  16. Spode
    Posted 8 years ago #

    Our Library is exploring an alternative library catalog interface. I am seeking a sitemap generator plugin which can handle the large number of entries/posts/pages in the system. Currently there are about 700,000. We can throw more RAM at it to a point, and speed of file generation is not very important. But the 50,000 link maximum for the file would be a problem. The sitemap specification says we can have an index page pointing to multiple sub-pages (up to 100, I think).

    Does this sitemap plugin have an option for enabling that kind of functionality? Could it start generating the first page, then when it hits 50,000 close that file and open another (freeing up all that RAM) and when the last is done, generate the sitemap index page?

    Or am I looking at this in the wrong way?

    See http://catalog.ust.hk/catalog/ for the WordPress installation I am planning to use this on.

    -Edward Spodick, HKUST Library, Hong Kong

  17. aboucolonblank
    Posted 8 years ago #

    Im running the latest version of Wp (2.3.3) and am having problems activating sitemap. Ive uploaded the latest version (3.0.3) but the plugin will only activate if i deactivate Akismet (2.1.4). The plugin works fine if akismet is turned off which i dont really want to have to do. Is there way to get these 2 great plugins working together in harmony?

  18. Manish
    Posted 8 years ago #

    Hi, I am using WP 2.3.3 and Google XML Sitemaps 3.0.3

    I want to exclude few categories from the sitemap being generated. There is an advanced option to exclude posts and pages but how do I exclude the entire category with existing and future posts in it. The option of putting category ID in the exclude box would be nice.

  19. stevehl42
    Posted 8 years ago #


    i'm still having the stylesheet problem. I deleted the URL in the section "Include a XSLT stylesheet" and saved it but I'm still getting this error when trying to go to my sitemap:

    "Error loading stylesheet: A network error occured loading an XSLT stylesheet:http://domain.com/wp-content/plugins/google-sitemap-generator/sitemap.xsl"

  20. allonline
    Posted 8 years ago #


    To anyone getting the sitemap.xsl error i had this one on one install even though i used the same extracted contents on each install and it puzzled me until i realised that the file is xsl but the filename had somehow changed to sitemap.xslt (t on the end) . Try renaming the file to sitemap.xsl if its just called sitemap.xslt and as long as the path is correct it should work. To check what filename is being looked for find your plain sitemap.xml file it should display ok in firefox might just say not stylesheet associated with it.

    i.e. Go to http://a-web-host.com and type in address bar http://a-web-host.com/sitemap.xml , right click and view source to see the code and check at the top the path and filename being looked for the stylesheet it should say sitemap.xsl only. Now using your ftp program look on the files uploaded to the plugin folder for the sitemap and see if the stylesheet is called sitemap.xslt if it is just rename it to sitemap.xsl you should find works it ok then when they match.



  21. arfo
    Posted 8 years ago #


    I get a message "Cannot load 1" when I click on the link to build for the first time, debug function or Save Options.
    I think that everything is correctly uploaded on my site, the sitemap.xml is in the site root and writtable.
    I even tried to generate a sitemap using an online site to avoid the "build for the time" operation but no change.
    I tried to uninstall the plugin, desactivate and re activate.
    I tried to desactivate all plugins excepted the sitemap generator... nothing.
    I tried a previous version (3.0.b6) of the plugin : same issue.

    My config :
    URL with no www : http://<name>.free.fr
    Wordpress 2.3.2
    Sitemap generator 3.0.3
    Permalink schema (I don't know if it can deal with the issue but...) : /index.php/%year%/%monthnum%/%day%/%postname%/
    Plugins :
    Askimet 2.1.4
    FeedBurner FeedSmith 2.3.1
    Simple Tags

    + others that are not related to tags or feeds or maps...

  22. arfo
    Posted 8 years ago #


    Just to let you know that my issue with XML sitemap generator seems to be solved. I think there were a conflict between this plugin and Simple Tag (v (that I have uninstalled). I have uninstalled some other plugins (as Post Rating) in the same time so I am not 100% sure of the conflict with Simple tag.



  23. allonline
    Posted 8 years ago #

    Just for information i just upgraded to WordPress 2.5 on http://www.topabc.com and the sitemap seems to be working fine, i have all search engines pinged with Yahoo key in use as well. Would still like to run this to a schedule using cron if anyone has done this, at the moment i go in manually and run it every few days.

    Absolutely hate the look of the admin colours in 2.5 far to glarey and also all the plugin layouts have changed have to scroll right down now to find the run link for the sitemap plugin.

    Would advise anyone running an earlier version to check there feed link is displaying ok as i found out my version 2.3.3 had been compromised by an iframe injection which broke the feed, another blog running the same version had the same problem site went off to some chinese stats php page.


  24. smanjolo
    Posted 8 years ago #


    I am a new guy at these things. I got the google-sitemap-generator from wordpress.org/extend/plugins/google-sitemap-generator/ and it is giving me these messages below. Help anybody:

    Warning: Unterminated comment starting line 781 in /home/lutha/public_html/wp-content/plugins/google-sitemap-generator/sitemap-core.php on line 781

    Parse error: syntax error, unexpected $end, expecting T_FUNCTION in /home/lutha/public_html/wp-content/plugins/google-sitemap-generator/sitemap-core.php on line 781

  25. Anonymous
    Posted 8 years ago #

    my site maps not working

    Rob Please check it out
    domain is http://www.rugbygamers.com
    sitemap is http://www.rugbygamers.com/sitemap.xml
    let me know if you have it fixed iv got a few old versions

  26. laslo
    Posted 8 years ago #

    My problem is with Google sitemaps on WP 2.5.1

    I just updated this plugin to avoid the "wp_post2cat doesn't exist for query" error. But I keep getting the same error:

    WordPress database error Table 'wp_post2cat' doesn't exist for query SELECT cat_ID AS ID, MAX(post_modified) AS last_mod FROM wp_posts p LEFT JOIN wp_post2cat pc ON p.ID = pc.post_id LEFT JOIN wp_categories c ON pc.category_id = c.cat_ID WHERE post_status = 'publish' GROUP BY cat_ID made by sm_buildsitemap, referer: http://www.xxxxxx.com/wp-admin/post.php?action=edit&post=7325

    sm_buildsitemap is Google sitemaps.

    I looked into google-sitemap-generator/sitemap-core.php and found a reference to $wpdb->post2cat on line 2023.
    I understand $wpdb->post2cat is deprecated, hence giving the wp_post2cat error. (that table doesn't exist on WP 2.5)

    Is that a plugin bug? Looks like it. How do I fix it?

    err... btw, I found that error on the log file of my server, it doesn't show up on WP admin. The plugin looks working fine, building the sitemap.xml and all, but the logfile shows that error.

  27. Anonymous
    Posted 7 years ago #

    hi there

    I am getting the following error after installing the v3.0.1 site map generator when i make apost on my blog my blog is
    WordPress 2.0.4 with DB 3440 on PHP 5.2.5

    Notice: Undefined variable: template in /home/termspec/public_html/wp-admin/admin-functions.php on line 1513

    and also

    /wp-content/plugins/google-sitemap-generator/sitemap-core.php on line 1316

    Plugin version: ($Id: sitemap-core.php 48034 2008-05-27 14:36:18Z arnee $)

    (yes i know its an old WP version but everything is (was) working

    everything seems to be working Ok exept this error comes up.

    if i then go to my blog the page i just wrote/updated is there ok but i can find any reference to this error anywhere


    anyone able to offer any help ?

    geoff Lord

Topic Closed

This topic has been closed to new replies.

About this Topic