WordPress.org

Support

Support » Plugins and Hacks » Google Sitemaps and WordPress 2.3 (Please help testing)

Google Sitemaps and WordPress 2.3 (Please help testing)

  • Hi,

    if you’re already using WordPress 2.3, the Google Sitemaps Plugin < Version 3.0b9 will NOT work for you since it tries to access database tables which don’t exist anymore. Please help me getting the new version in a stable state prior the WP 2.3 release.

    The current test release is 3.0b11. It works with WordPress 3 and uses MUCH less memory than the older versions. Please test it and report any problems so I can fix them until WP 2.3 comes out.

    Here is the download URL to the always most current version:
    http://downloads.wordpress.org/plugin/google-sitemap-generator.zip

    Thank you very much for your help! ๐Ÿ™‚

Viewing 15 replies - 16 through 30 (of 86 total)
  • Erwin
    Member

    @erwin

    No troubles at all here:

    http://strikdiploma.nl/sitemap.xml
    http://strikdiploma.nl/info.php

    WP 2.3, XML Sitemap Generator for WordPress 3.0.

    Keilya
    Member

    @fantasycrusader

    I’m running on 2.3 as well but whenever I upload sitemap.php to the plugins directory, the Plugins page refuses to load (so I can’t even activate it). Deleting sitemap.php brings the page back. I would really like to get this plugin running since it’s been a really long time when it stopped working for me.

    I’ve tried this only with one other plugin on my server – Akismet and the same thing happens. I think we can pretty much rule out interference from other plugins? =/

    Any ideas would be great!

    @fantasycrusader: I wrote you an email ๐Ÿ™‚

    DonPietro
    Member

    @donpietro

    I just upgraded to 2.3.

    When I try to activate this Sitemap plug-in, the Plug-in page goes blank and doesn’t show up again until I rename or delete the Sitemap folder. It does activate however and I can view the Sitemap Options in the menu.

    When I try to activate it in combination with the Google Analyticator plugin, it will trigger a fatal error.

    Any ideas?

    Thanks to bigbluelin letting me test what went wrong ๐Ÿ™‚

    The problem in this case was the memory usage of WordPress.

    Even with the Sitemaps plugin completely deleted from the system and no other active plugins, WordPress used 7.5MB of memory. Most PHP configurations allow only 8MB to be allocated, so using any other larger plugin will break the blog.

    I don’t know if the memory usage of 2.3 is significantly higher than of the older releases, but I will test it out.

    Possible solution:

    Open your wp-config.php file and add:

    @ini_set(“memory_limit”,”16M”);

    That will raise the maximum amount of allowed memory, but may not work on all blogs.

    @donpietro: is your PHP installation running as CGI? (phpinfo() output -> “Server API”) and could you try to raise the memory limit with @ini_set(“memory_limit”,”16M”);

    DonPietro
    Member

    @donpietro

    Not sure about the runnung as CGI thing, but I added the memory_limit like you suggested and it seems to work now.

    It did give a blank page again, but after refreshing the plug-in page still works now.

    Though, I think after I uploaded the new config.php file the UTF-8 code messed up a little.

    This is my blog btw: http://www.elperiodico.nl

    No sure why this happened since the config file is the exact same as before. Even after restoring the original one without the memory limit it’s still off.

    It might not even be a conflict with Sitemaps.

    Also, when I save new option settings in the options menu, I get redirected to /wp-admin/options.php resulting in a blank page with only the 2.3 footer info.

    Again, this probably isn’t a Sitemaps problem, but I just noticed it right now.

    DonPietro
    Member

    @donpietro

    Every plug-in I (de)activate will result in a blank page. As in, it doesnยดt return to the plugin page.

    Obviously some bigger problem is going here.

    EDIT: I restored the very original config.php from my WP version before I upgraded. The problems described above are now resolved.

    Not sure how to include the memory limit now since it messes other things up when I replace config.php.

    Keilya
    Member

    @fantasycrusader

    Hi DonPietro. The ‘symtoms’ you’ve described sounds very much like what I’ve had. Basically Arnee told me that WordPress was using more memory that what it was allowed, thus the page simply stops loading.

    If you would like to give this a try in wp-config.php, insert this:

    //Allow more memory.
    @ini_set(“memory_limit”,”16M”);

    Above this line:
    /* That’s all, stop editing! Happy blogging. */

    Upload it and see if it makes a difference. (:

    DonPietro
    Member

    @donpietro

    Fantasy,

    It does activate. But I will again get the other symptoms I described earlier (blank plug-in screen etc.) when I edit the original wp-config.php and upload it.

    dcaddick
    Member

    @dcaddick

    Hi,

    I have recently installed WP 2.3, along with XML Sitemap Generator for WordPress 3.0 at http://www.techagility.info and I keep getting an error:

    There was a problem writing your sitemap file. Make sure the file exists and is writable.

    I have made sure that I have the Gzip module loaded, I’ve installed empty files in the root – could someone please let me know how I can fix this?

    Thanks,
    DaveC

    Did you make these two files writable, via CHMOD 777 for example?

    DonPietro
    Member

    @donpietro

    I got it to work right now. Even the blank page problem is gone now after I click on activate.

    I copied the original wp-config.php and added the memory limit. (@ini_set(“memory_limit”,”16M”);) After that I uploaded it and everything seems to work.

    I must have had a bad copy of wp-config or something when I added the line before.

    Anyway, thanks for the support.

    TabrezIqbal
    Member

    @tabreziqbal

    Just reporting that the latest version of Google Sitemaps plugin is installed and is working well on my upgraded worpdress 2.3 blog. No database errors were spitout by the plugin in the dashboard and Google Webmaster page reports that it successfully downloaded the sitemap file(reported [roughly] correct no of urls).

    I did not go through the sitemap.xml file in detail but on a rough glance it appeared okay to me. Great work, arnee! Thanks.

    xavierp
    Member

    @xavierp

    DonPietro – thanks for posting your solution. I was getting a blank page after activation and by adding that line in I have the site map up and running. Thanks again.

    And thanks Arnee – it’s a very simple plugin and very effective.

Viewing 15 replies - 16 through 30 (of 86 total)
  • The topic ‘Google Sitemaps and WordPress 2.3 (Please help testing)’ is closed to new replies.