WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Google Sitemap Plugin producing XML error

[Resolved] Google Sitemap Plugin producing XML error

  • Hi all,

    I’ve installed Google Sitemaps 2.71 (http://www.arnebrachhold.de/2005/06/05/google-sitemaps-generator-v2-final) on my blog (WP-2.03), but I’m running into a strange error.

    When I try to access sitemap.xml.gz I get this page:

    XML Parsing Error: not well-formed
    Location: http://www.mysite.com/sitemap.xml.gz
    Line Number 1, Column 1:�
    ^

    But when I view sitemap.xml it loads perfectly.

    I checked the contents of the sitemap.xml.gz file from SSH using vim, and it appears to be formatted correctly. So I’m concluding that it is probably not a build issue.

    I’m think maybe something in the permalinks? I also have wp-cache installed, but I disabled it and still the same error.

    Any ideas?

    Thanks!
    Erik

Viewing 3 replies - 1 through 3 (of 3 total)
  • .gz are gzip archives, are you sure you’re supposed to be access that file particularly? .xml is probably the way to go.

    Trying to access it directly is a bit pointless. What you want to do is to figure out if Google is able to access it correctly, and you can do that by loading up the Google sitemaps page and seeing what it says about your site.

    Beyond what Google says about your map, it doesn’t make much difference what the browser displays.

    I just tried accessing it with lynx and it downloaded the file correctly. I guess I was a bit thrown when I got that error. I thought firefox would download the file since it was a *.gz…

    Thanks for your help!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Google Sitemap Plugin producing XML error’ is closed to new replies.
Skip to toolbar