Support » Plugin: Site Kit by Google - Analytics, Search Console, AdSense, Speed » Google SiteKit ‘redirect_uri’ mismatch

  • Resolved jrichardsoncorre

    (@jrichardsoncorre)


    I’ve tried deactivating, deleting, re-installing, and reactivating Sitekit but I get the same ‘redirect_uri’ mismatch error still.

    Settings > General doesn’t show my URL to ensure it’s set to redirect correctly.
    Tools > I do not see the option to reset SiteKit.
    Site Health shows good status with “Great Job, everything is running smoothly here”, with no issues detected.

    Any assistance is appreciated!

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    Thanks for reaching out and sharing the troubleshooting steps you’ve undertaken. If you’d like to share the following information we can investigate this further?

    1. Your Site Health information. You can use this form to share privately if preferred.
    2. During setup what is the URL in your address bar, on the same screen where you see this notice?

    If at some point you changes your site URL or wp-admin path while Site Kit was connected this could be the cause. If so one option is to reset the plugin(Tools > Available Tools > Reset Site Kit), which differs to deactivating, uninstalling and delating, none of which would delete your registered site records on the Site Kit service. Note that if you do reset the plugin all services will be disconnected for you and an other connected administrators if any. You’ll need to reconnect once more.

    Let me know if you have any questions with the above.

    Thread Starter jrichardsoncorre

    (@jrichardsoncorre)

    The URL on the screen with the notice is:

    https://sitekit.withgoogle.com/o/oauth2/auth/?response_type=code&access_type=offline&client_id=4ZgKxvYKGiKro4LsAF9wme-jVr8htyumAe9rRCwtPaGgJ.apps.sitekit.withgoogle.com&redirect_uri=https%3A%2F%2Fcorreinc.com%2Fwp-admin%2Findex.php%3Foauth2callback%3D1&state&scope=openid+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fuserinfo.profile+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fuserinfo.email+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fsiteverification+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fwebmasters+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fanalytics.readonly&login_hint=jrichardson%40correinc.com&prompt=consent&hl=en_US

    For tools, I don’t have “available tools”. Screenshot of what I see here:

    https://ibb.co/X2yv5B6

    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for checking. While we can reset your site on the Site Kit service that is unusual that you don’t see the “Available Tools” option. When you click on “Tools” rather than hover do you see the option to “Reset Site Kit” as per this screenshot.

    If not I’m happy to request a remote reset of your site. I’ve checked your Site Health information which you’ve kindly provided and nothing unusual stands out. Let me know how you get on with the above first.

    Thread Starter jrichardsoncorre

    (@jrichardsoncorre)

    That screenshot I sent is exactly what I see what I click on Tools, and I am admin for the site. I noticed your screenshot shows that you need to upgrade to WordPress 5.8.1, which is what I am using. I suppose that could be why, but no, I do not have “Reset Site Kit” anywhere in Tools.

    In Tools > Traffic, I do have a section for Google and Analytics as shown here. This appears totally separate from the Site Kit plugin, and I do have our Analytics Measurement ID there.

    If resetting the Site Kit will only effect Google Site Kit, then that’s potentially our solution. We’ve never actually used it but did install the plugin before the site went live.

    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for the update and further insights. I’ve requested a site reset now, from the Site Kit service. I’ll let you know once I have an update, at which point you can attempt setup once more.

    I’m also unsure of the cause of no Site Kit rest tool available from your own setup. This should appear on the latest version of WordPress also, not just the version I had installed within my previously shared screenshot.

    I’ll keep you updated once I have a response from the team that your site has been reset.

    Plugin Support James Osborne

    (@jamesosborne)

    Just to let you know we’ve reset a site record on the Site Kit service from what looks to me your site. Can you attempt setup once more and share whether you’re able to proceed?

    Thread Starter jrichardsoncorre

    (@jrichardsoncorre)

    I get a new error now when I click “redo setup”:

    invalid parameter: 'client_id'

    On the Site Kit Dashboard the Search Funnels, Acquisition, and Page Speed and Experience docks also say:

    Error: invalid 'client_id' or 'client_secret'

    I am not sure how to change the client ID or secret.

    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for the update. As I can’t be sure of the cause at this point can you share a screen recording of this behavior and I can discuss this with the team? When recording please keep your Chrome developer tools tab open, displaying console errors. You can use a service such as Loom or RecordIt to share, while using our escalations form to share privately if preferred.

    Alternatively if you prefer to perform additional troubleshooting steps I can provide some steps using the Health Check & Troubleshooting plugin.

    Thread Starter jrichardsoncorre

    (@jrichardsoncorre)

    Thanks, James. I’ve submitted a link to a screen recording.

    Plugin Support James Osborne

    (@jamesosborne)

    Many thanks for sharing. The video is super useful to see what’s occurring. May I ask what browser you’re using? While you’ve already checked for the previous “redirect_uri” error from a Chrome browser incognito window would it be possible for you to perform the below checks using incognito mode once more? I ask as some brosers have built in technologies such as Ad Blocks which can impact Site Kit setup and reporting.

    1. Reset Site Kit from within the plugin (you’ll find this option within the plugin settings that you’re connected – (Site Kit > Settings > Admin Settings > Reset Site Kit)
    2. Connect the plugin once more – while remaining in a Chrome incognito window
    3. Connect all other previously connected services

    If you encounter any errors along the way let me know. When connecting be sure to grant all permissions on the OAuth setup screen, the plugin requires these permissions to connect your site to the Google services.

    If the same error message appears from an incognito window we’ll then perform some additional checks, including with a non Google Workspace account.

    Let me know how you get on with the above, and appreciate you sharing that video.

    Thread Starter jrichardsoncorre

    (@jrichardsoncorre)

    Resetting the site kit through the Site Kit Admin Settings worked! Thank you so much for your assistance with this. I completely missed the Settings menu within Site Kit and the admin settings with the reset option there. I’d been looking only in Tools.

    Plugin Support James Osborne

    (@jamesosborne)

    That’s great, thanks for the update! And it was me who should have informed you that the “Reset” button also exists within the plugin settings. The issue I believed was you had this issue during setup, at which point users are unable to access their “Settings” – as the plugin wasn’t setup.

    Regardless let us know if you happen to encounter any further issues and we’d be happy to help. Best of luck with your site going forward.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Google SiteKit ‘redirect_uri’ mismatch’ is closed to new replies.