Support » Plugin: WP-Optimize - Cache, Clean, Compress. » Google Site Kit won’t work with Cache on

  • Resolved Ron the Web Guy

    (@ronthewebguy)


    I’ve been using WP-Optimize Premium and the Google Site Kit together for a while now. For some reason Google Site Kit errors in the WP dashboard when Enable page cache is on now.

    Not sure if one of the 2 plugins were updated recently… but my WP dashboard locks up and the Google Site Kit show big red errors until I disable page cache in WP-Optimize Premium. 🙁

    WP-Optimize 3.1.11 – running on: PHP 7.4.21, MySQL 10.2.39 – Linux
    Google Site Kit – Version: 1.36.0

    I tried adding /wp-admin/* to the URLs to exclude from caching but I still have this issue.

    • This topic was modified 2 months ago by Ron the Web Guy. Reason: added more details to help troubleshoot

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Support Harshad

    (@bornforphp)

    @ronthewebguy WP-Optimize doesn’t cache WordPress admin, `Have you performed a conflict test yet?

    If not – first, please make a full site backup.

    Try deactivating all plugins except for WP-Optimize and see if it is resolved.

    If so, reactivate each plugin one at a time until you find the culprit. You can check for the issue between activating each plugin, so you can see which one is causing problems.

    Please let us know your findings.

    Thread Starter Ron the Web Guy

    (@ronthewebguy)

    @bornforphp – yes: that is how I determined there was a conflict with the Google Site Kit plugin.

    The WP-Optimize plugin doesn’t cause the issue exactly. It’s only when I have the enable page cache option turned on and the Google Site Kit plugin active that the dashboard locks up.

    I can deactivate the Google Site Kit plugin and turn WP-Optimize page cache back on and all is good.

    I can turn off page cache in WP-Optimize and reactivate the Google Site Kit plugin and all is good.

    For some reason they don’t play well together. 🙁

    Plugin Support Harshad

    (@bornforphp)

    @ronthewebguy I’ll share this with our dveelopment team and see if we can work with Google Site Kit plugin authors to make it compatible.

    the easiest way would be to paste the google tracking code into your head!

    Plugin Support Harshad

    (@bornforphp)

    @penseelibre Thanks for sharing, @ronthewebguy Could you please try to paste the code into the <head> tag

    Thread Starter Ron the Web Guy

    (@ronthewebguy)

    @bornforphp – what code are you referring to? The Google tracking code? The main part of the Google Site Kit is that it integrates the Google Tracking Code into the WordPress site. If I add it to the <head> tag won’t it be in my code twice?

    I do not believe there is a way to turn off Google Analytics code from within the Google Site Kit so I am confused by this.

    Plugin Support Harshad

    (@bornforphp)

    @ronthewebguy Yes I eman the Google tracking code and disabling the Google Site kit plugin so the code doesn’t gets repeated twice?

    Thread Starter Ron the Web Guy

    (@ronthewebguy)

    Interesting… This just showed up on my site:

    Warning: The installed version of WP-Optimize Premium – Clean, Compress, Cache has not been tested on your version of WordPress (5.8). It has been tested up to version 5.7. You should update to make sure that you have a version that has been tested for compatibility.

    https://snipboard.io/Li2sdE.jpg

    Plugin Support Harshad

    (@bornforphp)

    @ronthewebguy You can ignore the warning from WordPress, we can confirm WP-Optimize is compatible with WordPress 5.8.

    We are releasing a new version, which should not show up the warning message.

    Thread Starter Ron the Web Guy

    (@ronthewebguy)

    @bornforphp – Deactivating the Google Site Kit plugin is not an option. It does way more than just add the Google tracking code to the website. I rely on it for dozens of websites.

    I am getting messages that WP-Optimize Premium – Clean, Compress, Cache is not compatible with WordPress 5.8 – this issue came up before the 5.8 update so I doubt its related… but it does hint to a possible issue with WP-Optimize Premium – Clean, Compress, Cache V 3.1.11 ???

    https://snipboard.io/KN08Q3.jpg

    Thread Starter Ron the Web Guy

    (@ronthewebguy)

    @bornforphp apologies – your message about ignoring the warning didn’t show up until after I posted mine. Please ignore my message. 😉

    Plugin Support Harshad

    (@bornforphp)

    @ronthewebguy no issues 🙂

    I use Google Site Kit with WP-Optimize and also have the errors in the Site Kit status display.
    I’m not using the WP-Optimize caching though, my whole site is cached through Cloudflare and it recommended not to use any other caching at the same time.
    I was wondering if my problem was Cloudflare, but maybe it is something else.
    Might be a clue hopefully.

    I have also had the issue with WP-Optimize Premium and have raised a ticket with the Google SiteKit team (https://wordpress.org/support/topic/additional-permissions-required-when-wp-optimize-cache-enabled/)

    I didn’t have the issue with the free version of WP-Optimize, ironically!

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.