Support » Plugin: TablePress » Google Sheets import adds extra columns and rows

  • Resolved tschrist

    (@tschrist)


    When I import from Google Sheets, the plugin seems to be adding extra columns and rows – and deleting multiple rows/columns is time consuming. Is there a setting that I’m missing? or is this expected?

    e.g. If I import a sheet with 10 columns and 20 rows, it shows up as columns A-GG, and rows 1-101 (all blanks after the imported data)

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your post, and sorry for the trouble.

    This indicates that your Google Sheet is returning those rows/columns in the URL that you are using for the import. TablePress then can not know that you don’t want these rows/columns. It simply has to import exactly what it’s given by the data source.
    Usually, this issue can be avoided when using a URL that directly returns a CSV file from Google Sheets, as that should only include the cells that actually contain data.

    Regards,
    Tobias

    hmm, is there a way to limit the rows/columns that google shares?

    I’m using the green share button in the upper right, it presents a URL – that’s the URL i’m using…

    and if not, can there be a multi-row, multi-column delete option? or range delete? you can only delete if you select an individual item

    • This reply was modified 2 days, 11 hours ago by tschrist.
    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    that’s likely the URL to the actual Google Sheet (including the full user interface, and not the CSV URL). You might have to use a modified URL:

    https://docs.google.com/spreadsheets/d/<DOCID>/export?format=csv
    

    Here <DOCID> needs to be extracted from your current URL (it’s a weird long string of letters and numbers).

    And yes, you can do a range-select: Just click the first row/column checkbox and then click the last one of the range while holding down the “Shift” key 🙂

    Regards,
    Tobias

    ah! magic! THANK YOU! changing to /export?format=csv and CSV format for import worked!

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    no problem, you are very welcome! 🙂 Good to hear that this helped!

    Best wishes,
    Tobias

    P.S.: In case you haven’t, please rate TablePress here in the plugin directory. Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.