Support » Plugin: Really Simple SSL » Google-selected canonical

  • Resolved kianakimm

    (@kianakimm)


    I used really simple ssl and submittde my https site to google search consul. Surprisinlgly google avoided to index my new https site as it considers my http site as canonical link.

    I use yoast seo but have no access to the setting of http to give them canonical link!

    Any advise?

    Thank

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Mark Wolters

    (@markwolters)

    Hi,

    have you checked if your Google settings are set up correctly? See https://really-simple-ssl.com/knowledge-base/how-to-setup-google-analytics-and-google-search-consolewebmaster-tools/ for instructions.

    Your canonical url does seem to be https:// now when checking the page source, so Google should index that.

    Mark

    kianakimm

    (@kianakimm)

    Hi Mark – my setting in google is correct for sure. But my http version of my website used to have coninical link to themselve and now your plugin override that and define https as the canonical.

    So I do not know what should i do with google?

    Plugin Contributor Mark Wolters

    (@markwolters)

    Since the canonical url is now https:// and the https:// domain has been added to Google, Google should now automatically index the https:// domain. This can take a few days before it’s visible in the search results. If Google still has problems indexing your site, it’s possible your sitemap still uses http:// links. You can re-save the Yoast settings to fix that.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.