Support » Plugin: Ecwid Ecommerce Shopping Cart » Google Search Console says: Invalid enum value in field ‘availability’

  • Resolved morktron

    (@morktron)


    Hi, I’m getting a message from Google Search console saying a couple of our Ecwid generated pages have invalid rich content

    It says that something in this code is the issue:

    <div class=”ecwid-productBrowser-details-inStockLabel” itemprop=”availability” role=”In stock” tabindex=”0″ aria-hidden=”true” style=”display: none;”>In stock</div>

    Is this something that needs fixing in the plugin or is there another way to resolve this? thanks

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi,

    Thanks for the report.

    The issue should already be resolved in the latest Ecwid storefront layout. Please try to enable it and let us know if that helps. Here is how to do that:
    1) Navigate to the “What’s new” section of your store settings (Ecwid dashboard -> Settings -> What’s New) and enable the “Next-gen Storefront” option there. It will enable the new layout of the store with a revamped design, features and SEO markup.
    2) Update the Ecwid plugin in WordPress to the latest version if you haven’t yet. You can do that on the “WordPress admin backend -> Plugins” page.
    3) Enable clean URLs in the Ecwid plugin settings — this is a must for SEO. Navigate to the Ecwid/Advanced settings in your WordPress admin backend and tick the “Clean SEO friendly URLs” checkbox there.

    When you’re done, please check it and let us know if you have any troubles.

    Thank you!

    Thread Starter morktron

    (@morktron)

    Perfect thanks Makfruit, I have done all that now and I’m sure it will be resolved now, many thanks indeed 🙂

    Plugin Author Ecwid

    (@ecwid)

    Great! The store looks nice with the new storefront. And it’s certainly more SEO-friendly now.

    The only thing left from the list is the clean URLs:
    > 3) Enable clean URLs in the Ecwid plugin settings — this is a must for SEO. Navigate to the Ecwid/Advanced settings in your WordPress admin backend and tick the “Clean SEO friendly URLs” checkbox there.

    I still recommend enabling them as this can be of a significant help for SEO.

    Thread Starter morktron

    (@morktron)

    Aha thanks, I thought I’d done that but I’d only done it in the Ecwid admin, not in the WordPress Ecwid admin.

    I made the change now in the development version which will go live soon, thanks again!

    “> 3) Enable clean URLs in the Ecwid plugin settings — this is a must for SEO”
    Where is that option? I cant see it.

    Plugin Author Ecwid

    (@ecwid)

    @escobarysanchez , that option is automatically enabled and hidden for the customers who signed up after we implemented it. So, your store already has it and it’s enabled.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Google Search Console says: Invalid enum value in field ‘availability’’ is closed to new replies.