Support » Plugin: LiteSpeed Cache » google search console errors

  • Resolved fluiddesk

    (@fluiddesk)


    Hey I have recently been getting errros on pages through the google search console, when loading them normally they look fine, but through googles search console they list as bullet points with the styles missing, this is what the top error looks like:
    Uncaught ReferenceError: jQuery is not defined at /wp-content/litespeed/cssjs/d3e0b.js?3c707:2:1

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    first of all , please go to Page Optimization -> Tuning setting :

    in JS exclude field , add jQuery

    in JS defer exclude field , add jQuery

    save and purge all , see how it goes

    if error still shows , then please also provide the report number

    you can get it in toolbox -> report -> click “send to LiteSpeed”

    Best regards,

    Thread Starter fluiddesk

    (@fluiddesk)

    Hey, thank you for the reply. I have added that although there was jQuery.js added in both of those options.

    That does seem to have resolved that although this was happening before but my pages for mobile during the google mobile test loads just the content as bullet points so the css isn’t loading, but If i run it again sometimes it loads fine and then othertimes its missing a few images but the styling is ok.

    I have tried quite a few different settings the past few days trying to fix this but haven’t had any success sadly.

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    okay , let’s do the old-fashion-way

    please go to toolbox -> import/export , export your current setting , then reset it to default setting , see if error still shows or not

    Best regards,

    Thread Starter fluiddesk

    (@fluiddesk)

    Hey I have just exported the settings I am actually getting more errors such as:

    Uncaught ReferenceError: jQuery is not defined at /wp-content/plugins/astra-addon/addons/woocommerce/assets/js/minified/single-product-ajax-cart.min.js?ver=3.1.0:1:2507

    Uncaught ReferenceError: jQuery is not defined at /wp-content/plugins/elementor-pro/assets/lib/smartmenus/jquery.smartmenus.min.js?ver=1.0.1:3:247 at /wp-content/plugins/elementor-pro/assets/lib/smartmenus/jquery.smartmenus.min.js?ver=1.0.1:3:256

    The contents was loading in bullet points due to none of the styling loading for the google search console test sadly

    Thank you, Regards

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    okay , if you disable LSCWP, do you see any error on it ?

    Best regards,

    Thread Starter fluiddesk

    (@fluiddesk)

    Hey, the same happens with the content loading just as bullet points, loading via an acutal mobile it loads fine its just google search console that I am having the issues with sadly

    Thank you, regards

    • This reply was modified 2 months, 1 week ago by fluiddesk.
    Plugin Support qtwrk

    (@qtwrk)

    huh ?

    Uncaught ReferenceError: jQuery is not defined at /wp-content/plugins/astra-addon/addons/woocommerce/assets/js/minified/single-product-ajax-cart.min.js?ver=3.1.0:1:2507
    
    Uncaught ReferenceError: jQuery is not defined at /wp-content/plugins/elementor-pro/assets/lib/smartmenus/jquery.smartmenus.min.js?ver=1.0.1:3:247 at /wp-content/plugins/elementor-pro/assets/lib/smartmenus/jquery.smartmenus.min.js?ver=1.0.1:3:256

    where you see this ? which page ? mobile/desktop ?

    Thread Starter fluiddesk

    (@fluiddesk)

    This was on mobile via the google search console “More info” tab

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    but if the issue still happens with LSCWP off, then you need to fix it from source first and then enable back LSCWP

    Best regards,

    Thread Starter fluiddesk

    (@fluiddesk)

    Hey should a site load fine with all of the content in the right place in the google search console test?

    Reards

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    If the site works properly on normal browser, yes , I suppose so

    Best regards,

    Thread Starter fluiddesk

    (@fluiddesk)

    Hey What is the best setting/s to eliminate render blocking respourses within Litespeed, I have one Query and one CSS file in there currently, i did try load CSS asynchronously but that caused quite big shifts when the page was loading

    Regards

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    yes, that’s the cost for remove render blocking on CSS

    as when you set it to load css async , HTML is loaded before CSS ,and you will get Flash of Uncontent Style.

    you can try enable Critical CSS to help to improve this behavior

    Best regards,

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.