Support » Fixing WordPress » Google search console errors

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator bcworkz

    (@bcworkz)

    Google shouldn’t be trying to index those files at all. I suspect it’s because your server is configured to allow directory listing. This is a modest security risk. You can possibly prevent this with a .htaccess directive. Via FTP, first download the .htaccess file in the WP installation folder to your computer. Make a backup copy. Open the file in a plain text editor and enter Options -Indexes at the very top of the file on its own line. Save.

    Upload the edited file back to the server. It’ll take a while for Google to figure out it shouldn’t index those files. You can hasten their removal through search console URL removal tool. It’s PITA because you can only do one URL at a time.

    Thread Starter elsoar

    (@elsoar)

    Really, Thank you bro, @bcworkz

    What should I write in .htaccess

    Moderator bcworkz

    (@bcworkz)

    Open the file in a plain text editor and enter Options -Indexes at the very top of the file on its own line. That’s all, two extra words added to whatever is already there.

    Thread Starter elsoar

    (@elsoar)

    @bcworkz
    Thank you very much, sir, you are a wonderful person.

    Moderator bcworkz

    (@bcworkz)

    You’re welcome. Mind you, I’m not certain this will solve the problem, but I think it likely will. It’ll help a little with security anyway.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Google search console errors’ is closed to new replies.