WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] google results

[Resolved] google results

  • auroraohio
    Member

    @auroraohio

    this is what shows up

    oliveaurora.org
    oliveaurora.org is powered by WordPress 2.0.5, K2 and 3 Column K2′ Terms of Service Current style is 3 Column K2 V 0.9 by Bharath Kumar …
    http://www.oliveaurora.org/ – 57k – Cached – Similar pages

    how do i change it

    thank you

Viewing 10 replies - 1 through 10 (of 10 total)
  • auroraohio
    Member

    @auroraohio

    I’d rather add something descriptive of my site.

    Kafkaesqui
    Member

    @kafkaesqui

    Looking at the source of your main page:

    <meta name="description" content="" />

    Might help to start there.

    auroraohio
    Member

    @auroraohio

    and i would be able to change tha in my theme editor i bet which file?

    greeenkaos
    Member

    @greeenkaos

    You should fill in the meta tag ‘description’ for your homepage. Right now it is blank. You’ll find it in the header.php file.

    I see you have meta tags for keywords in your single post pages. To add a description meta tag to those pages you could add

    <?php if ( is_single()) { ?><meta name="description" content="<?php the_excerpt_rss(); " /><?php } ?>

    to your header.php file. This will give you better descriptions for your single post pages. For your home or category pages you could add more conditional tags, for example:

    <?php if ( is_home()) { ?>
    <meta name="description" content="YOUR DESCRIPTION HERE" />
    <?php } ?>

    and so on for category pages, etc…

    Kafkaesqui
    Member

    @kafkaesqui

    Or…

    With K2, the line in your template will probably be, by default:

    <meta name="description" content="<?php bloginfo('description'); ?>" />

    So try adding something to the Tagline field under Options > General.

    auroraohio
    Member

    @auroraohio

    huh?

    durn now i are even stoopider.

    Kafkaesqui
    Member

    @kafkaesqui

    You are using the K2 theme. In the Header template (header.php), you would typically find this line:

    <meta name="description" content="<?php bloginfo('description'); ?>" />

    If you do, it means it is collecting the description (tagline) from your blog and outputting that for your description meta tag. And the tagline can be edited under Options > General in your WordPress admin.

    saintagnes
    Member

    @saintagnes

    I have this same issue. I want to change my Google search descprition that says “DJ Elle. © Worship Worthy Theme based on Benevolence by Theron Parlin. Syndicate this site using RSS – The latest comments to all posts in RSS …”

    How did “DJ Elle” get in there? Can someone tell me how to change this? I have a tagline in my OPTIONS>General setting but it’s not workng.

    Andrew Ozz
    WordPress Dev

    @azaozz

    1. Follow the advice by Kafkaesqui and remove that line from your header.php if there.

    2. Get another_wordpress_meta_plugin or similar and add meta tags to all your posts/pages.

    saintagnes
    Member

    @saintagnes

    Is there a way to just amend what’s already there? I have a meta plugin but there’s nowhere to write a description except where I already have one in the OPTIONS>tagline section. Here is what my header says right now:

    <?php if ( is_home()) { ?>
    <meta name=”description” content=”Downtown New York’s female authored lifestyle, events, art, fashion, and streetwear blog.” />
    <?php } ?>

    <meta http-equiv=”Content-Type” content=”text/html; charset=<?php bloginfo(‘charset’); ?>” />
    <style type=”text/css” media=”screen”>
    @import url( <?php bloginfo(‘stylesheet_url’); ?> );
    </style>

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] google results’ is closed to new replies.