Support » Plugin: Postman SMTP Mailer/Email Log » Google request isn't acceptable!!!!!!!

  • Resolved morteza13055

    (@morteza13055)


    Hi Great Postman 😉
    Tn first thank you for this nice plugin…
    But after configuring this plugin (+ Postman Gmail API Extension) & creating Google account ID & set on this plugin & testing connections(only 443 is open and set on postman smtp app), I send a request to gmail an accepted it but after redirecting to my site, no actions was accrued and it is not accepted… I refreshed the page and saw my google account permissions and no app was added (=”You haven’t granted any apps or websites access to your Google Account.”)

    please help me and excuse me for my Bad Descriptions.

    https://wordpress.org/plugins/postman-smtp/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Jason Hendriks

    (@jasonhendriks)

    Hi! Thanks for using the plugin.

    I refreshed the page and saw my google account permissions and no app was added (=”You haven’t granted any apps or websites access to your Google Account.”)

    I think you went to the wrong Google account permissions? Postman will not show up as an “app” anywhere except in the Developer’s Console.

    Did you follow the FAQ? Under “How do I get a Google Client ID? (For Gmail users only!)

    Hey!

    Thanks but I did them step by step with your great tutorials correctly. but after go to my account permissions by “Request permission from Google” and accept it “by accept button” in:
    “https://accounts.google.com/o/oauth2/auth?response_type=code&redirect_uri=http%3A%2F%2Fwww.mydoamin.com%……….” (writhed in it:
    By clicking Accept, you allow this app and Google to use your information in accordance with their respective terms of service and privacy policies. You can change this and other Account Permissions at any time.“).

    but after redirecting to “http://www.mydoamin.com/wp-admin/options-general.php?page=postman&state=*********************e&code=*/*********************-*******************”, no changes done.

    Test results (for smtp.gmail.com):
    For 25,587 and 465 ports:
    Outbound to Internet= closed
    Service Available= no
    other items= –

    For 443 port:
    Outbound to Internet= open
    Service Available= HTTP/1.0
    other items= No

    Conclusion:
    1- Port 443 can be used to send Gmail with the Postman Gmail Extension.
    2- Port 25 is blocked. Contact your host for a solution, such as using their local SMTP server or opening the port.
    3- Port 587 is blocked. Contact your host for a solution, such as using their local SMTP server or opening the port.
    4- Port 465 is blocked. Contact your host for a solution, such as using their local SMTP server or opening the port.

    Transport: Gmail API

    thanks a lot.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Thanks for the detail, I appreciate it. It certainly looks like everything should have worked.

    Obviously there is a problem which prevents the plugin from retrieving either the grant code or the access token. To fix this I suggest:

    1. You install the Debug plugin
    2. Enable WP_DEBUG_LOG
    3. Enable LogLevel DEBUG in Postman’s advanced settings
    4. Try the request again
    5. Send me the Debug Log!

      Will you do that?

    morteza13055

    (@morteza13055)

    Thanks for your help but my host client told me all of ports is open and I used my local smtp…
    your plugin is very nice and you are a good programmer but sorry… it seems this interfere with another plugin in my site.

    This problem doesn’t not reduce the value of your work…
    Thanks again..
    GOOD LUCK!

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    you’re using your host’s local server to send gmail?

    good luck to you too 🙂

    morteza13055

    (@morteza13055)

    hahaha…
    NO, I refuse it.
    your plugin and wp mail smtp not worked for me and I use easy mail smtp plugin (also,I can use my gmail account and my password with it)

    thanks again & sorry…

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    No need to be sorry, you are under no obligation to use my plugin. it won’t hurt my feelings if you don’t 😉

    In fact, you did exactly what my plugin told you to do: use your hosts’s local server. I have no idea what you mean by “seems to interfere with another plugin on my site” … that’s very vague. Which plugin?

    Anyway.

    Test if your setup works when sending TO someone with a gmail address before you declare it solved. in fact send a message TO me at jason – at – hendriks – dot – ca. My address is gmail.

    morteza13055

    (@morteza13055)

    I really tested it 10 hour ago and no need to test it again…
    Thanks.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Hello @morteza13055. I found someone with the same issue willing to help me debug. This issue has been fixed in Postman v1.6.6, marking as resolved.

    re: https://wordpress.org/support/topic/google-wont-grant-permission?replies=7

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Google request isn't acceptable!!!!!!!’ is closed to new replies.