Support » Plugin: Contact Form 7 » Google ReCaptcha v3 & Contact Form 7 Not Working

  • Resolved doshermanastuciudadhoy

    (@doshermanastuciudadhoy)


    Hello friends,

    Yesterday I was fighting with the forms of a web of a client, deactivate theme, all the plugins and everything and the problem continued, I gave the following error “There was an error trying to send your message. Please try again later.” when sending mostly with Google Chrome, although it also happened sometimes with Firefox.

    Finally, almost desperate, I decided to delete the Google reCAPTCHA V3 keys from the CF7 integration section and then the problem was solved. I have proof that I’m not the only one who is experiencing this problem, so I’m telling you to solve it and also that other users do not have to spend a bad afternoon like the one I had yesterday :-).

    a greeting

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 27 total)
  • There seems to be some reluctance by some to acknowledge this as an issue – blaming conflicts with other plugins.

    Very frustrating.

    I’ve rolled it back to the previous version until they acknowledge the problem and put out an update.

    Ironically – the contact form on the C7 website has the same issue.

    doshermanastuciudadhoy

    (@doshermanastuciudadhoy)

    Thank you very much for your comment @quantumstudio.

    regards

    How can you roll back to the previous versions?
    I ery much would like that to!

    Our server takes back ups periodically throughout the day – by rolled back, I mean I restored the site to before the 5.1 update 🙂

    Same problem here. I removed Google recaptcha and now the form works again

    Hi, in your console is a bug:
    Invalid site key or not loaded in api.js ?

    if so then you need to add a link to the api.js in your <head>
    Probably your site loaded api for recaptcha v2

    Code:
    <script src="https://www.google.com/recaptcha/api.js?render=reCAPTCHA_site_key"></script>

    more: https://developers.google.com/recaptcha/docs/v3

    Hi,

    I had the same problem as you guys. In my console there was an error with the plugin: “Autoptimize”.

    After deactivating some js-settings it works again.

    Same Problem, only solution was to delete the Google reCAPTCHA V3 keys from the CF7 integration section.

    Another bad afternoon. Please fix this!

    • This reply was modified 8 months, 3 weeks ago by hansbeen.

    You need to get a new key as v3 is a different API.

    Having the same issue on a number of sites that use CF7 with reCAPTCHA V3.
    All sites have new API keys but just won’t send out unless we remove the key :/

    The fact that this is an ongoing issue for the last 9 months or so is very concerning

    Tonis_troubles

    (@tonis_troubles)

    I’m having te same issue on numerous sites. The only option I found is to remove the site keys. And get used to the spam.

    On my own site I got rid of Contactform 7, and went with GravityForms (not great either). If anyone knows of another form that works just fine with V3. Pls let me know!

    ravenmore

    (@ravenomore)

    Any news on this? Encountered the same problem. I reverted to recaptcha V2 via a different plugin. Better than nothing but it seems the bots have already defeated V2 to some extent.

    Still a problem here as well. Deactivate v3 as the only option.

    @tezet
    Your solution worked. I added the script to an html file.
    Thanks.

    The Google script code must be in the HEAD section of the page. If you use Autoptimize, you need to prevent the plugin from being moved below the fold.

Viewing 15 replies - 1 through 15 (of 27 total)
  • You must be logged in to reply to this topic.