Support » Fixing WordPress » Google Reader feed munged by fetch_rss

  • Resolved illovich

    (@illovich)


    I’m trying to set up a sidebar link list based on items I’ve shared from Google Reader, and I’m having a weird problem.

    Basically, the links are munged in such a way that the link is either the actual link plus the first part of the url again, or in the case of links that come from feedburner feeds, the feedburner link plus the firest part of the original link.

    For example, a link from a feed entry from musicthing (blogspot) will be:

    Mouseover for URL example

    While a link from createdigitalmusic (which uses feedburner feeds) will be this:

    Mouseover for URL example

    I’ve been playing with some various ideas on my wp site I’m developing http://ilovich.com/wp and if you go there, you can see the various attempts (using both wp_rss and fetch_rss and getting the same result).

    My guess at this point is it’s somewhere with the underlying RSS system (MAGPIE?) used by WP, since this is the only place my feeds look like this. I’ve tried looking at the RSS feeds directly and they seem fine, and they are interpreted correctly by my browsers if I navigate to them directly.

    I also tried using a feedburner feed of the google feed, and got the same result.

    Is there possibly a way to see what fetch_rss is returning? I can see the link and title elements in the code from the fetch_rss documentation:

    <?php require_once(ABSPATH . WPINC . '/rss-functions.php'); ?>
    <?php $rss = fetch_rss('http://example.com/rss/feed/goes/here'); ?>
    <ul>
    <?php foreach ( $rss->items as $item ) : ?>
    <li><a href='<?php echo $item['link']; ?>'
    title='<?php echo $item['title']; ?>'>
    <?php echo $item['title']; ?>
    </a></li>
    <?php endforeach; ?>
    </ul>

    …but I’m not clear how to see the entire parsed feed in the item array.

    Thanks in advance for any insights. 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The answer turned out to be stupider than I thought, lol.

    The problem was being caused by Google Reader distributing an ATOM feed, not RSS. I guess fetch_RSS doesn’t also parse ATOM feeds. =P

    Anyway, I was actually able to fix it using Feedburner. I burned my Google Reader RSS feed and used their feedconvert feature to change it to an RSS 2.0 feed, which seems to work fine.

    Woot.

    Tell me more. I am experiencing the exact same problem.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Google Reader feed munged by fetch_rss’ is closed to new replies.