Support » Theme: Sydney » Google Ranking CLS

  • thalakus

    (@thalakus)


    Hello together,
    I’ve seen that in the web vitals of google some pages with the sydney theme are rated bad regarding the CLS value.
    Also https://demo.athemes.com/themes/?theme=sydney shows a value of the Cumulative Layout Shift (CLS) of 0.97 in the field-data.

    It measures the changes made for visible text while or after loading without user-interaction.

    Since from may2021 on this is gonna be a ranking factor I’d love to know if there’s a improvement for that.
    On my page I also tested it with all plugins deactivated and it still occurs with a red-value of the CLS.

    Best regards and happy easter!!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter thalakus

    (@thalakus)

    So I analyzed some of the pages from this support-forum and found out the following:
    the bad CLS only occurs on the start-page with the big slider. BUT even if the slider only shows 1 picture with a time of “0” (no movement).
    All other pages like /products etc. have a good CLS value.

    I’m sure we’ll find a solution and make Sydney even better!! Have a nice easter

    Hi,

    Thank you contacting us and pointing out about CLS.

    CLS seems likely would be worth adding in future versions Sydney. Surely, we’ll be putting it to our roadmap as it.

    But please remember that CLS analyzer tools could not implicitly mention which parts/elements are from theme, plugins, or somewhere else. Since you may use additional plugins or third-party scripts on your website, so you may investigate their CLS as well.

    Regards,
    Kharis

    Thread Starter thalakus

    (@thalakus)

    Hello Kharis,

    thanks for your reply!
    I tested it without plugins and it remains the same. As I said, it mainly occurs on the main-page with the Slider but slider-activity -0 so it just shows the “rich-style-picture” and the text.

    Also the same on other pages I tested. The score on the other subfolders do look good but only the main starting page with the slider is ranked badly. Though changing it to “picture” is no option because I want it to take the full monitor and I love the look of sydneys headerslider with the fonts above.

    Sure we’ll fix that!

    Have a great day

    Thread Starter thalakus

    (@thalakus)

    Hello Kharis,
    I found out that it’s only on the main page with the slider. I want to keep the slider but 1. I have deactivated changing pictures (time = 0) and 2. I noticed that the text is “flying” into position. I guess thats one reason the bad CLS.. As I said all other sub-sides work perfectly. Only the Start-page with the slider is like that…
    Best regards!!

    • This reply was modified 3 weeks, 3 days ago by thalakus.

    Hi,

    Can I ask whether disabling ‘flying’ text animation on the main slider could help or not? Please confirm.

    If so, it would be better if you can provide a link to your website here, so I can do direct inspection.

    Regards,
    Kharis

    Thread Starter thalakus

    (@thalakus)

    Hi Kharis,
    the additional CSS improved it a little but not much. Like from 0.78 to 0.71
    It should be under 0.1

    I think it’s not a page specific thing, because I analyzed multiple different Sydney-Pages from other users and always came to the conclusion that it’s mainly the start-page that has these values.

    Maybe you have a look onto some of your testpages with your developer, when the slider + text is activated.

    Best regards!!

    Thread Starter thalakus

    (@thalakus)

    Hi Kharis,
    checked it also now with a blank new Sydney-Installation and a clean new WordPress – still the ratings for the CLS-Score are in the red area…
    Maybe it’s worth analyzing the theme with your developers since it’s gaining more significancy for the google-rating.

    Best regards!

    yuccatrees

    (@yuccatrees)

    Hi,
    I have the same problem, which was temporarily resolved by disabling the Slider on the homepage. Hope to see the slider improved on future updates!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.