Support » Fixing WordPress » Google Preview showing a cached page

  • I deleted an “under construction” plug-in about 24 hours ago, but weirdness followed. My site shows up in Google with “under Construction” in the preview, and when I do a search for a particular page, the Google preview shows it as a cached page – no images, just text. I know my site it live. When I deleted the “under construction” plug in yesterday, I couldn’t see a deactivate button, so just deleted it. I have a feeling this could be the problem? One I don’t know how to fix? Also, I went into my ftp folder and the plug-in isn’t listed, so I know I don’t have it anymore. Sadly, I can’t even remember the name of it. Got a big black screen with Under Construction and Coming Soon if that sounds familiar to anyone.

    My site is http://www.vintageart.ca

Viewing 4 replies - 1 through 4 (of 4 total)
  • Google’s server’s and index are not updated instantaneously or necessarily even in a day. Wait a few days and see if it changes. Have you submitted your site to Google via webmaster tools?

    Huh? :))
    Where do I find that. It may only be a .ca, but in Canada it is already showing up in the third slot for keywords vintage+art, so I’m assuming it’s indexed. Is there something else I should be doing?

    I’m about to search for webmaster tools. I’m pretty sure I’ve done this already. I guess I’ll have to learn patience.

    Thanks for your help.

    Found Webmaster tools, working on the verification thingy now. Thanks again for your help.

    Edited to add ..
    … and why does Google make these things so complicated. Need to look for a youtube video. LOL

    Edited to add …
    … used a plug-in … made it easy.

    Now back to being patient. thanks again

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Google Preview showing a cached page’ is closed to new replies.