WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Google plus only posting title only, without the link

[Resolved] Google plus only posting title only, without the link

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author NextScripts
    Participant

    @nextscripts

    pixelkicks
    Participant

    @pixelkicks

    Thanks for your reply. We’ve forced the update through by double clicking API, but the problem is still ocurring.

    We have the latest version of WordPress, and:

    3.4.1
    Nextscripts: Social Networks Auto-Poster
    1.2.1
    Nextscripts: SNAP Pro Upgrade Helper

    None of the plugins show any further updates available. We purchased the extra Google+ specific plugin a while ago. Is this now integrated into the main plugin or do we also need to update that by downloading it from your site manually?

    Plugin Author NextScripts
    Participant

    @nextscripts

    What is the full version number do you see in the plugin settings?

    It should be:

    Plugin Version: 3.4.1 (API Version: 2.15.42) [Pro – Multiple Accounts Edition]

    Hi,

    I’m having the same problem, even though i’ve updated the API. “Plugin Version: 3.4.1 (API Version: 2.15.42) [Pro – Multiple Accounts Edition]”.

    The logs show that the post has gone through (and it has) but there is no “attached blogpost”. Can i provide any further information to help debug this issue?

    Edit: I am catching some warnings, not sure if relevant

    file: “/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/inc/nxs_functions_adv.php”
    line: 39
    message: “Undefined variable: pt”

    stack: Array[4]
    0: “nsFormatMessage()”
    1: “nxs_doPublishToGP()”
    2: “nxs_rePostToGP_ajax()”
    3: “do_action(‘wp_ajax_rePostToGP’)”

    file: “/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/nxs_functions.php”
    line: 447
    message: “preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead”
    stack: Array[8]
    0: “preg_replace()”
    1: “nxs_html_to_utf8()”
    2: “nxsAPI_GP->postGP()”
    3: “doPostToGooglePlus2()”
    4: “nxs_class_SNAP_GP->doPostToNT()”
    5: “nxs_doPublishToGP()”
    6: “nxs_rePostToGP_ajax()”
    7: “do_action(‘wp_ajax_rePostToGP’)”

    This is while reposting an existing post.

    pixelkicks
    Participant

    @pixelkicks

    This is what I get:
    Plugin Version: 3.4.1 (API Version: 2.15.42) [Pro – Multiple Accounts Edition]

    mdidesign
    Member

    @mdidesign

    In my case there is just the text when auto-posting to Google+. The blogpost does not appear, especially not the post-image. Something is wrong here and should be resolved.

    mdidesign
    Member

    @mdidesign

    BTW: I am using the latest API (like mentioned on your page), but there is still no attached link to the post (and therefore no picture). So what shall we do?

    The new API version (2.15.43) has fixed this issue for me.

    mdidesign
    Member

    @mdidesign

    The API version did not fix it for me. Still the attached blogpost does NOT appear. Just the text – no blogpost, no image. Everything is correctly set up. I am using the PRO version of the plugin – and the plugin author does not answer at all. Great support, thank you!

    Are you actually on 2.15.43 (not .42)? It came out on July 22nd. http://www.nextscripts.com/updts/news/2014/07/new-google-api-2-15-43/

    I agree that support sucks, the issue should at least have been acknowledged before the silent update was issued. Just curious, did you open a ticket as well?

    mdidesign
    Member

    @mdidesign

    Yes, when opening the plugin-page, this is shown:

    Plugin Version: 3.4.2 (API Version: 2.15.43) (Pro – Multiple Accounts Edition).

    mdidesign
    Member

    @mdidesign

    Correction: The API must have been updated automatically. Now Google+ auto-posts work. Why did the author not publish a news here in the forums or by using the plugin-ability of WordPress? I did not update the plugin manually, there was no information on the plugins page, nothing. How can this API been updated automatically?

    With 2.15.43 it works now. But it would be better if the author would communicate those things to us users.

    mdidesign
    Member

    @mdidesign

    … but Twitter-posts still get truncated without a reason. There are much letters left to use.

    It updated automatically for me as well, it is documented that it does so. Even though a notification in *any* of these threads from Next Scripts would have been the professional thing to do.

    pixelkicks
    Participant

    @pixelkicks

    This works now, thanks.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] Google plus only posting title only, without the link’ is closed to new replies.