Support » Plugin: WooCommerce Amazon Pay » Google picking up amazon pay query string

  • Resolved aclancy

    (@aclancy)


    Google is picking up query strings with Amazon Pay in Search console. In my case there are over a thousand listed under “Crawled – currently not indexed” . They look like this:

    https://my-website-name/page/1336?s&amazon_payments_advanced=true

    The only difference between the many hundreds of links is the number, so /page/904?s…, /page/97?s…, etc

    I stopped using Amazon Pay and deleted the plugin with all the directories and files over two years ago but these links are still crawled by Google as late as yesterday.

    In trying to figure this out I found this link somewhere: https://my-website-name/wc-api/wc_gateway_amazon_payments_advanced.

    This link returns -1 when clicked, not a 404 as I would expect because there is no /wc-api/ that I can see in my website structure. There is also no /page/ in my website structure that I can see. I have no idea where these urls are coming from.

    I would like to figure out what is causing Google to think these pages exist and resolve the issue.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter aclancy

    (@aclancy)

    Update: I figured out that /page/ is the wordpress default search structure and not something relating to this issue. It looks to me like the issue is ?s&amazon_payments_advanced=true is being appended to every url on the website somewhere, somehow, or for some reason Google is seeing that and counting it as a page and creating errors in Search Console. The reason this is confusing is because I don’t use Amazon Pay and haven’t for years.

    Plugin Support Christian

    (@christian1983)

    Hey @aclancy

    Hope you are doing well!

    I will check with the development team and get back to you.

    Best,

    Christian

    Plugin Support Christian

    (@christian1983)

    Hey @aclancy

    Hope you are doing well!

    Your case seems really old. The URL you are mentioning **/wc-api/*** is the WooCommerce Legacy API path. It could be that you may have uninstalled the plugin, not through the WP interface, and the permalinks were never flushed.

    If you made a URL flush, by visiting Settings > Permalinks and simply clicking save, google should start picking up updated status code responses.

    Also for the URLs already indexed, you could create 301 permanent redirects to start fixing your indexation issue.

    Only a suggestion, it could be there is something else going on in the background that we are not aware of.

    Let me know if this helps.

    Best,

    Christian

    Thread Starter aclancy

    (@aclancy)

    Thanks for looking into it. I saved the permalinks as you suggest but I don’t think that’s going to do anything. I visited the /wc-api/wc_gateway_amazon_payments_advanced page after saving the existing permalink structure and it still returns “-1”, meaning the page loads and that page is blank except for “-1” in the upper left corner.

    Plugin Support Christian

    (@christian1983)

    Hey @aclancy

    You can try with a redirect configuration. Using plugin like https://wordpress.org/plugins/redirection/

    here it’s an example: https://ibb.co/WcjJ0mq

    Let me know.

    Best,

    Christian

    Thread Starter aclancy

    (@aclancy)

    Thanks for the suggestion. What I would like most is to figure out where this is coming from. Can you suggest places to investigate? Since I don’t have the Amazon Payments plugin installed any more, could it be coming from the woocommerce files? A management file like htaccess? The database? Somewhere else?

    It exists somewhere. If I can find the source I can probably figure out how to remove it.

    Thanks again.

    Edit: Actually I figured out that any random thing I type as a URL past:

    my-website.com/wc-api/

    returns “-1”, which I take to be a negative response from /wc-api/

    so “my-website.com/wc-api/xxxxxxx” returns -1

    This doesn’t strike me as a problem. If there is a chance “&amazon_payments_advanced=true” is still being outputted somewhere, and you have an idea where, please let me know. If it’s just an artifact in Google Search Console from the past, and it’s not a URL being generated by my website, I will assume those URLs will drop out of Google in time as Google figures out they don’t exist.

    Thanks again.

    • This reply was modified 1 year ago by aclancy.
    Plugin Support Christian

    (@christian1983)

    Hey @aclancy

    Hope you are doing well!

    Your last response is correct. As long as the amazon pay plugin doesn’t exist, nothing we can do about how WooCommerce treats legacy API endpoints. Google should start picking up that these URLs are invalid.

    Best,

    Christian

    Plugin Support Christian

    (@christian1983)

    Hey @aclancy ,

    Since we haven’t heard back from the OP in a while, I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

    Best,

    Christian

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Google picking up amazon pay query string’ is closed to new replies.