Support » Plugin: Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others » Google Photos only visible when logged in

  • Resolved Els Guns

    (@els-guns)


    The photos currently visible on the page are a standard WP image gallery. Google Photos code is above it. All is looking fine when logged in into WordPress.

    • This topic was modified 4 months, 1 week ago by Els Guns.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Sayontan Sinha

    (@sayontan)

    This is probably coming from whatever is setting your script loading to async (maybe a different plugin that you have installed to perform some sort of optimization). Basically Photonic’s JS is not getting executed on your site. Your photos are all present, but Photonic performs a step at the end once all photos are loaded – it makes the photos visible. Try disabling the plugin that is setting the async attribute on Photonic’s scripts. Currently you have this showing up:

    <script nomodule async='async' src='https://www.lgomorika.be/wp-content/plugins/photonic/include/js/front-end/nomodule/combo-slider/photonic-baguettebox.min.js?ver=20210413-64848'></script>
    <script type='module' async='async' src='https://www.lgomorika.be/wp-content/plugins/photonic/include/js/front-end/module/combo-slider/photonic-baguettebox.min.js?ver=20210413-64848'></script>
    

    I believe if you are able to get that async='async' removed, things will work.

    Thread Starter Els Guns

    (@els-guns)

    Hi Sayontan
    Thanks for your quick response! I disabled the plugin that added ‘async’ and all is working fine again. Thanks for your awesome plugin!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.