Support » Plugin: Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others » Google Photos Displayed As Green Squares

  • Resolved skatedog

    (@bsidestv)


    I’m running WP 5.8 with Photonic 2.74 and pics from Google Photo albums are displayed as small green squares(no thumbnail). Pictures can be viewed when selecting one of the squares but aren’t displayed on the post. I’ve looked through the settings but couldn’t find anything that would reset it. Any ideas?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Sayontan Sinha

    (@sayontan)

    I am not at a computer, so I cannot troubleshoot this, but generally this happens if you have a lazy-loading plugin that replaces Photonic’s photos with placeholders.

    Thread Starter skatedog

    (@bsidestv)

    I was experimenting and it seems that it may be a bug with “square thumbnail grid, lightbox” because I just toggled to other settings like “circular thumbnail grid, lightbox” and “Masonry layout, lightbox” and those work.

    Plugin Author Sayontan Sinha

    (@sayontan)

    I am fairly certain that is not the case. The square thumbnails+lightbox setting is the default and has been so for about a decade, and is what is active on several thousand websites.

    Anyway, if you still have it active during the weekend I can take a look.

    Thread Starter skatedog

    (@bsidestv)

    I have it set to “Masonry layout, lightbox” for now. I can change it back when you have time to take a quick look.

    Plugin Author Sayontan Sinha

    (@sayontan)

    If you can provide me with a URL with the problem active, I can take a look.

    Thread Starter skatedog

    (@bsidestv)

    Plugin Author Sayontan Sinha

    (@sayontan)

    Yes, as I had said in my first post, this is happening because of lazy loading. You seem to have turned it on via Jetpack, and possibly other plugins. If you switch that off, you should be fine. Photonic cannot build its layouts if you use a lazy-loading plugin, since it does not know what your image sizes are.

    Additionally, you might have enabled caching (via a plugin or via .htaccess) or a CDN. Caching does not work if you are displaying Google Photos, since the URLs generated by Google Photos have a life of ~30 minutes. As a result, none of your galleries are loading for me, regardless of the layout. If you want to continue using your caching method, you have to either exclude the Photonic pages from it, or you have to switch to the JavaScript mode for loading your galleries (via Photonic → Settings → Google Photos → Google Photos Settings → Layout Processing Mode).

    Thread Starter skatedog

    (@bsidestv)

    Hi, after disabling lazy loading and checked .htaccess for any caching (no code specifying that) and for a few pages, everything was visible. However, with the newest page, it isn’t- https://tinyurl.com/4tvses43

    It shows a spinning circle like it’s trying to load the photo album. This is occurring on multiple browsers, computers. What else can be checked? There aren’t any plug-ins that are caching.

    Plugin Author Sayontan Sinha

    (@sayontan)

    You still seem to be serving cached copies – the simplest indicator for this is the fact that when I first loaded your page, it loaded fine, but about an hour later I started getting errors from Google with code 403, which mean that your site is serving stale data from caches.

    When you say that you “checked .htaccess for any caching”, what did you look for? Did you try contacting your hosting provider? Many hosting providers have default settings to cache pages for 30 days or so, and they tend to do this to help score higher on PageSpeed.

    If you are not sure how server-side caching is set up on your site, I cannot offer more help along those lines.

    Have you tried following my suggestion about the layout mode above? Your site still seems to be following a PHP layout method.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.