Support » Plugin: Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others » Google Photos Authentication Problem Error 403

  • Resolved robertjanke

    (@robertjanke)


    Hi

    I have followed your instructions but still getting Error 403. Desktop Client didn’t work, so I used Web Client. Put in the 3 URIs, used the Client ID and secret. Got to the page where I can select my account but after that Error 403. I tried the workaround. I disabled all Plugins. Allowed unrestricted API key access. Still can’t authorize.

    Any idea? Thanks!

    The page I need help with: [log in to see the link]

Viewing 6 replies - 16 through 21 (of 21 total)
  • Plugin Author Sayontan

    (@sayontan)

    I have tried another Google account now. I set-up the Desktop client. After providing Client ID and Secret in Photonic WP and hitting Authenticate I get “Authorization Error
    Error 400: redirect_uri_mismatch”. How can there be an uri mismatch? I haven’t provided any redirect uri because that option is only available for Web, not Desktop.

    I really don’t know about this one.

    However, given the challenges you were facing, I went ahead and redid all the steps from the start. I set up a new project, set up a desktop client etc. … and just like you, I faced a 403 error when I tried using this client.

    At that point, I tried something very simple – the place where you see “Publish App” in the OAuth Consent Screen, I went ahead and published the app. And this made the whole thing work.

    So if you still have your older project, you might want to try publishing it and see how it goes.

    Let me know if this works – if it does, this would be yet another instance of Google changing the design without notifying people.

    • This reply was modified 1 month, 2 weeks ago by Sayontan.
    Thread Starter robertjanke

    (@robertjanke)

    Unfortunately that didn’t work for me. I also deleted the entire project and started a new project from scratch again. Since late yesterday I don’t even get the Google account selection screen any more, which was followed by 403. Since late yesterday I’m now getting “Error 400: redirect_uri_mismatch”. That applies to both, Photonic Desktop Authorization and Web oauthplayground. Since I have started from scratch again, I don’t see any misconfiguration on my end.

    According to the instructions, there are only two Redirect URIs to copy and paste for Web oauthplayground:

    https://robertjanke.de
    https://robertjanke.de/wp-admin/admin.php?page=photonic-auth&source=google

    and on OAuth 2.0 Playground:

    https://www.googleapis.com/auth/photoslibrary.readonly https://www.googleapis.com/auth/photoslibrary.sharing

    Compared to the instructions, the oAuth Consent Screen also contains 3 more steps: Scopes, Test users, Summary. I didn’t do any entries there, correct?

    Click here for screenshots.

    Thread Starter robertjanke

    (@robertjanke)

    By the way, wouldn’t be an easy way of accessing Google Photos Albums (or Photos/ Videos) be to use the “Share URL” from Google Photos? I haven’t found a single Plugin or website that offers that service. Unfortunately, Google only allows to share individual albums (photos/ videos) via individual URLs but doesn’t provide a platform to access all shared albums (photos/ videos). Just a plugin or platform where users can copy and paste the individual “Share URLs” from Google Photo and all these albums, photos/ videos will then show up.

    • This reply was modified 1 month, 2 weeks ago by robertjanke.
    • This reply was modified 1 month, 2 weeks ago by robertjanke.
    Plugin Author Sayontan

    (@sayontan)

    The OAuth2 Playground requires the third redirection URL as well (see the first step of the workaround documentation), and it will only accept the web client ID. While setting up the redirection please ensure that you don’t have any trailing spaces or tabs.

    The Share URL is useless from a plugin’s point of view. You cannot find out what photos are on the page and you have no control over the display etc. Basically the share URL is only good for embedding the whole page and nothing else.

    Thread Starter robertjanke

    (@robertjanke)

    It’s working now! The third URL was missing for the Web OAuth2 Playground! Totally my fault, but it might be better to add the third URL to the description at the top or move everything to the bottom. Thanks for your help! I just bought you a coffee… or beer for that matter. 😉

    In terms of the Share URL, the admin who inserts the Share URL into the plugin would know which albums (photos/ videos) he wants to share. The plugin only would have to show all those underlying Share URL albums in a nice grid, same as Photonic does now with the authentication. Instead of selecting the albums visually, they would be selected by copy & paste the Share URL. It should be easy to program and very simple set-up without authorization, just copy & paste Share URLs.

    Plugin Author Sayontan

    (@sayontan)

    The plugin only would have to show all those underlying Share URL albums in a nice grid

    Simple though this sounds, this is practically impossible 🙂

    Basically what you are suggesting is a “URL scraper” – something that will parse through the contents of an HTML page and figure out what images are being used over there. This puts you very much at the mercy of Google – if they change one small thing with their markup, the logic to do the URL scraping will fail, causing the plugin to stop working. Considering the frequency with which Google changes things, this approach is a recipe for disaster.

    The other challenge with this approach is that the grid on the page may have low-resolution, smaller images. You will have no way of finding out the full resolution image that needs to be shown in the lightbox.

    I had considered handling shared URLs earlier, but the challenges listed above are insurmountable.

Viewing 6 replies - 16 through 21 (of 21 total)
  • You must be logged in to reply to this topic.