• Resolved chennaimath

    (@chennaimath)


    Hi,
    We are facing issue in the google photo authentication setup. In Photonic -> setting when we click step 1 authenticate -> Google photo with our valid email id it shows that “This App is not verified”
    Here are the screenshots.
    https://rkmath.d.pr/MpyYkr
    https://rkmath.d.pr/99uYdx

    Could you please let us know how to proceed further?

    With best regards,
    Ramakrishna Math

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Sayontan

    (@sayontan)

    Another user faced an app verification issue, but wasn’t able to rectify it.

    I provided a workaround for that person, which you might want to try:

    1. In the screen where you have set up your client id (on Google itself), add this to your list of Redirect URLs: https://developers.google.com/oauthplayground. After you have finished the entire authentication process you can delete this URL.
    2. Go to the Google OAuth2 Playground.
    3. On the right, under the configuration select the option to “Use your own OAuth credentials”. Provide your client ID and secret there.
    4. On the left, under “Step 1 Select & authorize APIs” in the box next to “Authorize APIs”, put in https://www.googleapis.com/auth/photoslibrary.readonly https://www.googleapis.com/auth/photoslibrary.sharing https://picasaweb.google.com/data/, then click “Authorize APIs”.
    5. You will go through the authentication screens, and finally, the section under “Step 2 Exchange authorization code for tokens” gets activated. You will see an “Authorization code” populated, and you can “Exchange Authorization code for tokens”
    6. That will get you the “Refresh token” and the “Access token”. Copy the “Refresh token” and save it under Photonic → Settings → Google Photos → Google Photos settings → Refresh Token (for Back-end / Server-side Authentication).
    Plugin Author Sayontan

    (@sayontan)

    Hi,
    Following up – were you able to get this resolved?

    Hi,

    I tried this but it didn’t work. It’s still giving me a 403 error. http://prntscr.com/nzdis6
    http://prntscr.com/nzdizc

    I’ve disabled all plugins I can. Any other suggestions? Thanks!

    Plugin Author Sayontan

    (@sayontan)

    @tpaul25,
    In accordance with forum rules please start your own thread instead of posting on old, closed threads started by others. I will respond there.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.