Support » Plugin: WP 2FA - Two-factor Authentication for WordPress » Google Passcode Authentication not working at installation

  • The plugin, which looks great, unfortunately is not working. It does not accept the passcode generated by google authenticator during the installation. Neither the wizard nor the installation through users > WP 2FA works.

    To the folks at WP White Security, I’ll be happy to share further details/screenshots if that’s helpful. Please email me directly through my wordpress.org account or reply to this message with an email address I can contact you at.

    Thanks.

    EDIT: The plug in is working correctly. The issue is with the NTP / chrony daemon on the Linux server. The issue on the server side has been resolved and the plugin is working correctly.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor robertabela

    (@robert681)

    Thank you for using our plugin @zarraqztech

    I am sorry you are encountering issues. Can you please send us an email at support@wpwhitesecurity.com? We’d like to look into this issue.

    Looking forward to hearing from you.

    zarraqztech

    (@zarraqztech)

    Hi, Robert.

    I dug into the problem on our end and have seen that out ntp on the server is out of sync. I’ve resolved the NTP issue and also tested the plugin and it sporadically works. But this is mainly because of the time on the server not synchronising properly. At this point, I don’t think it’s an issue with the plugin, but an issue on our server.

    I’ll be happy to update the original rating I gave based on this on WordPress.org. Is there any way for me to do that?

    Also, users have reported that when the account gets enabled and 2fa is enforced, they don’t get an option immediately at the point of login to setup 2fa. They login and on the dashboard there’s a message saying their grave period as started. I’m assuming that the plug is working and the NTP issue isn’t causing this, so is there anyway to get the user to see a screen to setup their 2fa immediately after they’ve entered their password? Like with 2fa setup on outlook.com etc – you succees with your password and the next screen says you have to setup 2fa to proceed.

    Thanks.

    zarraqztech

    (@zarraqztech)

    Also, I’ve amended the original review and given a 5 star rating.

    I’ll be grateful if you can respond back to my question about getting the user to set their 2fa immediately after entering their password.

    Thanks.

    Plugin Contributor robertabela

    (@robert681)

    Glad to hear the problem was not from our end and thank you very much for updating the rating. Really appreciated.

    We have been looking into adding the option to enforce 2FA straight away and we will for sure add it. The next update is already scheduled, so most probably we will update it in the update after the next one.

    Thank you very much for using our plugin.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this review.