Support » Plugin: GA Google Analytics » Google Optimize not working – errors

  • Resolved hifunda

    (@hifunda)


    Even after entering the Custom Tracker, I am unable to use Optimize on my site. I can see the container ID inserted in my page source. I am using gtag.js in your plugin settings, and not the legacy code. I currently block Admin tracking. I get these two errors:

    1. Optimize plugin not found
    The web page page doesn’t have Optimize plugin for the container ID (GTM-KS7BJF7) installed. You can still use the visual editor to create variants but you can’t use Preview mode to test them and visitors won’t see your experiment. To run an experiment you must first install Optimize .

    2. Unsupported Analytics tracking code
    The page is tracked with the legacy Google Analytics (ga.js) tracking code which isn’t supported by Optimize. Update your Google Analytics tracking code to either analytics.js or gtag.js to use Optimize.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Jeff Starr

    (@specialk)

    Definitely sounds like a bug, I will investigate and try to resolve for the next plugin update. Thank you for reporting, @hifunda. Fee free to post again with any further questions or feedback, etc.

    Thanks for your reply, sorry for the late update.
    This is still happening by the way. Unable to use Google Optimize for A/B testing.

    Is it fixed please?

    Plugin Author Jeff Starr

    (@specialk)

    No not yet, currently working on a big project. I will try to address this for the next plugin update, which should coincide with the next major WordPress update.

    Ok thanks, looking forward to the update and fix!

    Plugin Author Jeff Starr

    (@specialk)

    Hi @hifunda, I’m working on updating the plugin and can’t seem to replicate the described issue. Can you let me know what code you are using for the following plugin options:

    – Custom Tracker Objects
    – Custom GA Code
    – Custom Code

    That will enable me to recreate your configuration and continue to investigate. Thank you!

    Note: if you would rather send the code privately (instead of sharing it here), you can reach me directly via my contact form.

    • This reply was modified 6 months, 1 week ago by Jeff Starr. Reason: adds contact info
    artemglazkov

    (@artemglazkov)

    Hi Jeff,

    Just found out that GA Google Analytics puts require command from Custom GA Code before create:

    
      ga('require', 'GTM-xxxxxxx');
      ga('create', 'UA-xxxxxxxxxxx', 'auto');
    

    In all examples they are vise-versa.
    Maybe that’s the root of the problem?

    Plugin Author Jeff Starr

    (@specialk)

    Very interesting, can you please share some examples where the order is reversed? I ask because all options/output for the plugin follow the corresponding Google docs as closely as possible. Thank you.

    artemglazkov

    (@artemglazkov)

    Here an example from Install Optimize using analytics.js official guide:

    <script>
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
    
      ga('create', 'UA-XXXXXXX-X', 'auto');
      ga('require', 'GTM-XXXXXX');
      ga('send', 'pageview');
    
    </script>
    Plugin Author Jeff Starr

    (@specialk)

    Thanks I will investigate and try to resolve any issue.

    Plugin Author Jeff Starr

    (@specialk)

    Just to follow up with this, the reported issue is resolved in the upcoming version of the plugin, should be available within the next several days or so. Thanks again for reporting, @artemglazkov. Please let me know if there are any further issues, questions, etc.

    I am having the exact same issue. You were saying this latest version did fix it? Or it will be coming soon? Thanks for the help!

    Plugin Author Jeff Starr

    (@specialk)

    Yes the issue is resolved in the current version of the plugin.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.