Support » Plugin: Google XML Sitemaps » Google not indexing some sitemaps

  • I’m not sure where to research this.

    I have a valid sitemap i submitted to Google.

    for one, it surprised me that when i submitted it, it took several days before it came out of the ‘pending’ status. I thought the indexing happened within 24 hours. is this not the case? (it’s been several years since I worked on google and sitemaps).

    Anyway, second. I have submitted a sitemap. in Google it says it has it. it says ‘submitted’ and the page count is correct. then it says ‘indexed’ and it’s empty. None of those pages are getting indexed.

    I’m trying to understand why this would happen.

    Is there a place I could talk to someone that knows this process very well? i’m assuming this isn’t the right place to ask for support about something like this, but other than a knowledge base at google, i don’t know of a forum i could post this question to

    • This topic was modified 1 month, 2 weeks ago by  viruseater.
Viewing 3 replies - 1 through 3 (of 3 total)
  • FYI i should add, i did read the sticky and all of the requirements listed have been met

    Hi
    I have the same issue i am seeing nothing in my google console that a sitemap has been added or submitted. Can anyone please clarify why this is happening.
    Can any other senior member with experience here please let us know if this plugin is working.
    the plugin it says it has been submitted, but nothing is showing.

    My problem was the sitemaps yoast produced were not getting indexed.

    I was referenced to this page: https://www.xml-sitemaps.com/ on the yoast forum where I asked about this (not by their support, just another user)

    Using that I created a static sitemap that google indexed correctly.

    I don’t know what else to do now, because obviously it’s not dynamic

    • This reply was modified 1 month, 2 weeks ago by  viruseater.
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.