Support » Plugin: Google XML Sitemaps » Google Not Indexing My Sitemap

  • jamm

    (@mybrandreview)


    Hello, For the past 10 days since I switch my sitemap to Google Sitemap Generator, I have been having series of sleeplessness because all my contents have refused to be indexed and my blog is not making any sense. Google sitemap shows they are been crawled but not indexed. Could this be an issue caused by the generator or Google itself?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • A similar problem for several months. As a result, it turned out that this damn plugin was to blame.

    Please note that the plugin put the tag <meta name = “robots” content = “noindex, follow”> in your site map https://jammuzic.com/sitemap.xml

    I myself do not know how to solve the problem. Need to contact the developers.

    • This reply was modified 3 weeks, 6 days ago by  fedorov.

    Hi,
    I am facing the same issue since last two months.

    Thanks for mentioning the cause.
    Let me also contact developers to see if this is the case with my site as well.

    Hey I am using this plugin on multiple wordpress sites.

    All of these websites have <meta name = “robots” content = “noindex, follow”> in sitemap XLS stylesheet.

    But the sitemap isn’t get indexed in Google only for the one website; that is get indexed for all other sites.

    So I don’t think this is the problem.

    Does anyone else encountered this issue and fixed it? Please suggest.

    joshibhargav20

    (@joshibhargav20)

    Fixed:

    Keep in mind that when Google displays “Couldn’t Fetch” could also mean “Pending”. You would wait for about an hour to a day to see if status is changed.

    If this status is not changed (that was in my case), then change the sitemap plugin; and it will work. In my case when I changed the plugin, then it worked.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.