Support » Plugin: WP Google Maps » Google Maps Still Not Working After PHP Upgrade!

  • Resolved needforname

    (@needforname)


    I’ve inquired about this problem already and was told I have to upgrade my PHP and that it would solve the problem. I’ve upgraded the PHP to 5.6 and am still receiving errors and unable to activate the WP Google Maps plugin.”[wpgmza id=”1″]” appears on my web page, and the following error below appears in my WordPress plugin page:

    WPParse error: syntax error, unexpected T_STRING in /home1/arcocapi/public_html/wp-content/plugins/wp-google-maps/wpGoogleMaps.php on line 602

    I’ve tried all versions of php 5.6 and all versions of 7.0, and nothing resolves the issue. Not only did the plugin crash the website and lock me out of wp-admin access, it still won’t function despite upgrading the PHP. Can someone please assist with this? Your plugin is the only maps plugin that achieves what were looking for, so I really need to get this working. The error message on the site looks very unprofessional.

    Thanks for any assistance.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Hi there

    Please see here for my response on your other thread.

    I’m terribly sorry to hear this, begging your pardon for any inconvenience caused.

    The line causing this error is the following:

    $wpgmza_google_maps_api_loader = new WPGMZA\GoogleMapsAPILoader();

    The only way this can fail is if your PHP version doesn’t support namespaces, eg WPGMZA\ which have been supported since PHP 5.3

    Can you please either create a phpinfo file or use a phpinfo plugin to make absolutely sure the version switch has been applied?

    Can you please also confirm your ticket reference so that I may request details through there?

    Kind regards
    – Perry

Viewing 1 replies (of 1 total)
  • The topic ‘Google Maps Still Not Working After PHP Upgrade!’ is closed to new replies.