Support » Plugin: WordPress Shortcodes Plugin — Shortcodes Ultimate » Google maps no longer working

  • Resolved Autosoft B.V.

    (@autosoftbv)


    We use the [gmap] tag a lot,
    but recently the iFrame content (maps.google.com) can not be loaded.
    (connection refused)

    We know you have to use an API key nowadays,
    but we can’t seem to find any configuration page for Shortcodes Ultimate that allows us to fill in an API key.

    Please help out.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi
    Yes I noticed that too!

    Google maps not showing up. There’s a sad icon face and a note…
    “maps.google.com refused to connect.”

    Maybe google isn’t working, unusual I know!

    I did an inspection on the page and it came up with this red note…

    “Refused to display ‘https://maps.google.com/’ in a frame because it set ‘X-Frame-Options’ to ‘sameorigin’.”

    Any idea what this means as I havn’t a clue?

    Cheers

    It seems that Google have drop this embed map url (this url gives 404)

    https://maps.google.com/maps is now https://www.google.com/maps/embed

    Thread Starter Autosoft B.V.

    (@autosoftbv)

    Hello @silvermuru , we’ve noticed that too and tried to change it within the plugin file itself, (includes/shortcode/gmap.php) but weren’t able to solve the problem.

    The new url uses different variables that don’t match the plugin itself.
    I think it _may_ have something to do with the redirect Google applies on the maps url.

    A fix would be a Javascript version with your own API-key, or an entirely new approach.

    Using the standard Google maps embed iFrame code still works as a temporary solution.

    Thread Starter Autosoft B.V.

    (@autosoftbv)

    A possible fix, based on the use of an API-key

    The old output:

    //www.google.com/maps?q=[ADDRESS]&output=embed

    Should be replaced with:

    //www.google.com/maps/embed/v1/place?q=[ADDRESS]&key=[YOUR-API-KEY]

    Vladmir –
    Not certain, for myself – what changed on various fronts from 3:50am local time (here) and 5:15 pm local time (again!) here! But I awoke to do site maintenance and experienced the ‘maps not showing” and started iframe with API key direct embedding, but after a mid-day break, logged back into remaining sites and their maps showing up fine! No CHANGES made for direct embed with API key – did you push out something on your end, OR didn’t I completely flush caches as I should, or …?

    Will do ‘my part on my end” and I have Pro bundle add purchased ages ago, but since not in last 6 months? Posting here, in free support repository, because Gmaps thingee open on free option?

    Thanks for all you do and just posting for other’s knoweledge and to say, once more! Love your tool and all that you do on the free repository option!

    Google have made now automatic redirect to new api and old maps should work without API key again like before

    Thread Starter Autosoft B.V.

    (@autosoftbv)

    Seems to be working fine now.
    Maybe Google did have a bug or updated something?

    Sorry for the inconvenience I may have caused.
    Let’s just hope it stays up and running.

    (allthough an option with an API-key would still be very much appreciated since we are obligated to use one as requested by Google)

    @autosoftbv – I’m glad you posted, because then I knew, it wasn’t just me! Glad it got resolved and will keep an eye out for any API things as they come down the pike! 🙂

    Not just you at all. We went through the same thing… found that all of our sites had Google maps failing. Experimented with OpenStreetMap, Bing plugins, found an acceptable OpenStreetMap one and implemented on one site… then Google maps was magically working again. I hope they will at least notify people of such a change in the future — or better still, have the redirect working first!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.