Support » Plugin: Complianz - GDPR/CCPA Cookie Consent » Google Maps never displayed as long as plugin is active

  • Resolved Hanno

    (@bsoftde)


    Plugin detects script, changes script type to ‘text/plain’ and inserts ‘class=”cmplz-script”‘, as it should. But even if the user consents to using Google Maps OR Google Maps is entirely marked as not connected in the integration tab, nothing changes. The only way to get Google Maps displayed again is to deactivate the plugin.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    Hi @bsoftde,

    This is of course not how it should work. Can you post a link to your website so we can take a look?

    Thread Starter Hanno

    (@bsoftde)

    Hi Rogier,
    unfortunately the site is still under construction and not yet online. As there are certain restrictions on Google Maps API, we will probably have to wait until the site is accessible from outside.
    I will get back to you later.

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    @bsoftde here’s a link how it normally works. Maybe it will help you track it down.
    https://demo.complianz.io/placeholders/google-maps/

    If not, we’re happy to help you out if you have some more info for us.

    Thread Starter Hanno

    (@bsoftde)

    Well, that example does not help. I use Divi page builder, and the philosophy of implementing Google Maps seems to be quite different from that of Elementor, which you use. Especially, there is no iframe object which, as I see it, is the main hook for your blocking mechanism. Instead, the Divi module uses a script link to googleapis.com/maps, which I can’t find at all in your demo site.

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    @bsoftde, that is helpful information.

    Such a setup should not be a problem, but it’s possible divi uses a custom script to load the maps.

    Possibly there is an inline script which also needs to be blocked, and maybe requires a dependency to ensure the scripts are activated in the correct order.

    I’ll see if we can setup a map with divi to test this.

    Thread Starter Hanno

    (@bsoftde)

    I could also provide you with a complete sourcecode of one of the webpages affected, if that would be of any help for you.
    If so, please advise how to proceed.

    • This reply was modified 2 years, 4 months ago by Hanno.
    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    I’ve been testing with how Divi does this. In most cases an implementation like Divi uses is built by some inline script, in combination with the googleapis.com/maps script. Blocking both the inline script and googleapis.com/maps, then ensure they execute in the correct order works just fine.

    The problem with Divi is that they put scripts which enable services like Google Maps and recapctcha in their core front-end javascript code. This causes issues with blocking as other features may also break. But even when I block this front-end script it’s not firing on activation. This suggests they’re waiting for some event that isn’t firing anymore at this point.

    For now, I don’t think it’s possible to dynamically block and activate Google Maps with Divi generated Google Maps.

    To achieve this, Divi would have to split these services scripts from the ‘core’ scripts so they can be blocked separately, or they can integrate with the WP Consent API, which is a WordPress feature plugin which is expected to get merged into core within a few versions.

    For now, there are two options: you can disable the Google Maps integration/remove the blocked scripts from your script center, or you can use a different maps embed tool. There are several Google Maps plugins which have integrations in Complianz (Google Maps Easy, WP Google Maps, WP Google Maps widget), and most custom maps scripts can be made to work with a few adjustments.

    I’m sorry I can’t be of more help at this point, but hopefully Divi will step in and make some adjustment to make it possible to get a GDPR compliant website.

    Thread Starter Hanno

    (@bsoftde)

    Thank you for your reply.
    I changed one page to using the WP Google Maps plugin instead of the Divi module.
    It works as it should, although I am not very keen on implementing one plugin after another, if there is a built-in solution one could use. Every plugin brings its own security risks.
    BTW, please have a look at this info which shows below the Google Maps window:
    Um Google Maps-Cookies zu aktivieren, bitte auf ?Ich stimme zu? klicken
    The question marks should be German opening resp. closing quotation marks. Don’t know where the problem is, the .mo file has the correct characters.
    CU

    Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @bsoftde,

    We will have a look at why the sudden change to ?Ich stimme zu?.. Regarding how Divi adds Google Maps; we have created a solution for Divi (and others) and opened a ticket to their support desk, and on Github to explain the Consent API.

    Unfortunately, that’s as much as we can do on our end. You can log a ticket at Divi and refer to this thread, we’re happy to assist if needed. Until then, I will close this topic.

    regards Aert

    Hi @aahulsebos I would like to know if there are any improvements with this case. We have 170 divi maps in a website and we would like to use Complianz plugin as well.
    Thank you

    Thread Starter Hanno

    (@bsoftde)

    Hi all,

    @silviaetnonautas: If you need a quick solution there is no choice but switching to a different map solution. I decided to use “WP Google Maps” which interacts perfectly with the Complianz plugin. Besides, compared to the simple divi module, I was surprised to see all the additional features the plugin offers.
    As Elegant Themes do not use the Consent API, and switching to that API would probably mean a major code change, I suppose we will not see any compatible module in the near future.

    @aahulsebos: There is still that ugly ?Ich stimme zu? in the German po file, which could be fixed very easily (and I would not have to edit the po file every time there is a new update from you).
    Here is the correct snippet from the po file:

    #: integrations/plugins/wp-google-maps.php:23
    msgid "To enable Google Maps cookies, please click \"I Agree\""
    msgstr "Um Google Maps-Cookies zu aktivieren, bitte auf \"Ich stimme zu\" klicken"

    I would highly appreciate if you could include this tiny change in your next update.
    Tx Hanno (@bsoftde)

    Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @bsoftde, @silviaetnonautas,

    This is the current situation: https://snipboard.io/X7bfD8.jpg

    The point is, it doesn’t show correctly on the front-end, but we can’t change the string in translations, because it will be corrected again by the moderators.

    We will now change the string completely, so it needs another translation. This time, without any quotes.

    regards Aert

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Google Maps never displayed as long as plugin is active’ is closed to new replies.