Support » Plugin: Events Made Easy » Google Maps MissingKeyMapError

  • Resolved Ben Kaminski

    (@tzhben)


    I’ve been using your plugin for a while and have yet to see this. I just deployed a site using the plugin and it’s now looking for a Google Maps API Key. So, in other words, the map won’t load on the event’s page. It begins to load then a JS alert pops up which looks like this:

    JS Error Example

    As well, using the “inspect element” of Chrome I was able to ascertain this:
    Console Error

    Is this a known bug? I have yet to see this before. Any help would be greatly appreciated because as of now, the maps aren’t working on the website.

    Thanks.

    https://wordpress.org/plugins/events-made-easy/

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Franky

    (@liedekef)

    Are you sure it is EME needing the API key? My google js doesn’t need one, but google might track you and force you to use one if you use it too much (I think, but never saw it happen).
    See this event, works fine here: http://www.e-dynamics.be/wordpress/?page_id=495&event_id=880
    Is there a test event you can show?

    If you look at the console warning, it looks like you are using a “retired version” in “util.js” on line 20. But it’s not really my place to hack your plugin.

    Google is starting to force everyone into getting API keys for maps usage. Perhaps adding to your plugin an input to allow the user to use their unique API key would be helpful.

    Here’s the description of “retired version” from https://developers.google.com/maps/documentation/javascript/error-messages#deverrorcodes

    “You may have supplied a retired version in your script element. The versions 3.0 – 3.22 have been retired, and you might be receiving 3.23 instead. Please update your application to use one of the available versions.”

    Here is a “test” event… but any event will provide the same problem:

    Events

    Plugin Author Franky

    (@liedekef)

    I’m more inclined in saying that the popup is due to the iframe you use in your page:

    <iframe class="embed-responsive-item" src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d3093.6661795687137!2d-75.52247638451277!3d39.159573639052184!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x89c764a947a257a7%3A0x5a26dc5e21e818b!2sFraizer's+Restaurant!5e0!3m2!1sen!2sus!4v1459560260277" style="margin-top:-120px;border:0; height: 420px;" allowfullscreen></iframe>

    Could you try if disabling that changes anything? Because you can see my example url which uses the exact same plugin and shows the map without problems.

    Already tried that with no luck, but for the purpose of this conversation, I have re-commented it out.

    Please re look at the page source to verify.

    I’m convinced it’s not coming from the <iframe> embed.

    In fact, I’ve gone so far as to replace my embed entirely with a static image linking out to further try to rule out the <iframe> as the issue.

    thank you.

    Plugin Author Franky

    (@liedekef)

    Well, indeed it seems to be coming from google itself. Maybe indeed for new apps they require an API key again. Sigh …
    I’ve added an option for this:
    https://plugins.trac.wordpress.org/changeset/1443497/

    If you find implementing this changeset too difficult, try downloading the dev-version in one go:
    https://downloads.wordpress.org/plugin/events-made-easy.zip

    Of course, don’t forget to add your API key in the new setting.

    Thanks Franky, I really appreciate it and totally agree with you on the Google products. But, in hindsight, didn’t we all know this would eventually happen? LOL. Either way, I agree with “sigh” because that’s exactly what I did when I saw the notification.

    I will try to implement this by tomorrow at the latest and will report back with success or failure. But thanks for taking fast action here. It’s very much appreciated.

    Thanks again Franky!

    Franky,
    I’ve installed the Dev version of the plugin and have added my API key to the correct line. Thank you for adding that!

    Unfortunately, I can only confirm that the maps now work on the Dashboard only. When I used to go to Events -> Locations -> Edit Location, I would get the same JS error I’ve posted a picture of before. I no longer get this error on the dashboard and the map successfully renders within your plugin from the dashboard.

    On the public facing side, I’m getting a different error, no more JS alert, now it’s an “Oops, Something went wrong.” warning, I inspect console and it’s telling me I’m using an invalid API key. I’m convinced this API key is valid, I have used Maps API’s for years now.

    So, my question is, can you look again and give me your thoughts? Maybe the API data isn’t carrying over to the front end, as it’s clearly now working in the dashboard?

    Just for reference I have the following API’s enabled through Google:
    -Google Maps Embed API
    -Google Maps Geolocation API
    -Google Maps Javascript API
    -Google Static Maps API

    Are there any I’m perhaps missing that I should enable?

    Thanks for all your help Franky. You can check the same URL I posted before as a test event if you can.

    Thank you.

    Plugin Author Franky

    (@liedekef)

    Small typo (on 1 line), this should fix it:

    https://plugins.trac.wordpress.org/changeset/1443739/

    Mark it RESOLVED Franky!!!

    Thank’s so much for you’re help with this. Your prompt attention and willingness to solve the issue speaks volumes for the quality of your work and the deliverables you distribute.

    Keep up the excellent work, your plugin is very useful and user friendly.

    Thanks again for everything!

    -BEN

    Plugin Author Franky

    (@liedekef)

    Nice to hear it works now!

    where do i get the api key and where do i add it?

    Thanks

    Plugin Author Franky

    (@liedekef)

    The next version will contain a setting for the google maps api key, and a link to the google pages to get it (although searching for “google maps api key” will get you there too).

    I was having the same issue so followed your changelog to update the code, created an api key with google and added it into the new field in Settings however I get a ‘Something went wrong error’ on both the live site and in admin?

    i have also tried uploading the dev version and its still the same, won’t work in either admin or on the site. Any ideas would be really appreciated

    Plugin Author Franky

    (@liedekef)

    Please inspect your browser console for hints.
    Also, make sure that your API key has the right referrer restrictions, otherwise it won’t work.
    I just tried the dev version: works just fine with a google api key.
    Edit: also make sure the API “Google Maps JavaScript API” is activated (the other ones are not important) and that the API key you created is a “browser key” in google. These are both the defaults for google, but one may never know …

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Google Maps MissingKeyMapError’ is closed to new replies.