Support » Plugin: Essential Real Estate » Google Maps Issue on creating a property

  • hi there!

    I was wondering if anyone faced an issue with google maps loading when adding a property? I get an error saying “This page can’t load Google Maps correctly.” when going to the location tab in the editor. I have verified the key etc. and they look good to me. I am doing this on my local server.

    Please do let me know!
    Thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author g5theme

    (@g5theme)

    Hi, Google has some changes with Map API: http://geoawesomeness.com/developers-up-in-arms-over-google-maps-api-insane-price-hike/ so, you got an error when load goole map.
    Please create new Google map API key http://prntscr.com/kamuct https://developers.google.com/maps/documentation/javascript/tutorial#api_key
    Or try to use my key: AIzaSyBqmFdSPp4-iY_BG14j_eUeLwOn9Oj4a4Q
    Thanks

    Plugin Author g5theme

    (@g5theme)

    Please update version 1.5.6 and create new google map API key or use my key: AIzaSyBqmFdSPp4-iY_BG14j_eUeLwOn9Oj4a4Q
    Thanks

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @g5theme Is that really a good idea? You made the decision to post your API key and it won’t be edited later because you did that intentionally.

    Plugin Author g5theme

    (@g5theme)

    Dir Moderator, That’s just the api key I created for free but it is limited to use and for long-term use, the user should create his own API key. Thanks Mod

    I generated a new API key, all the new maps are defaulting to Sydney, Australia. ERE doesn’t not find the new property address when adding a new property. I sent google a ticket for help. Below is their reply.

    From the google maps team:

    Thank you for the information.

    Inspecting your code for the map on location, you are instantiating a new map with coordinates -33.86383886517223, 151.20401675140374 (see screenshot 1). Those coordinates lead to a place in Sydney:
    https://google-developers.appspot.com/maps/documentation/utils/geocoder/#q%3D-33.863839%252C151.204017
    This is why the map in Sydney is shown.

    On property 3, the coordinates are -33.868419, 151.193245 (very close to the above), which is why it is located in Sydney as well. (See screenshot 2)
    https://vilaggio.net/property/1065-gold-rock-ln-morrisville-nc-27560/

    If you look at the other maps that render correctly, for example property 5
    https://vilaggio.net/property/125-s-harding-ave-anaheim-ca-92804/
    this loads a map with coordinates 33.8309805, -117.99928080000001 (screenshot 3)

    Your application generates these different map with a location attached to them, for each of the property pages. You (or your developer) are more familiar with where and how that is generated, but what I can tell is that you are sending down html pages which load a google map with incorrect coordinates. Please note this is not a bug with the Google Maps API. If you give it coordinates in Sydney, then it will show a map in Sydney.
    I advise you (or your developer) to check why these pages generate incorrect coordinates).

    Kind regards,
    Thomas
    Google Maps Platform support

    • This reply was modified 1 year, 5 months ago by tarzan61.

    This problem is happening on my site also. I have purchased the Beyot theme and see the same problem in the forum; however, both places have not provided a solution that solves the problem.

    In addition, to the Syndey map problem – when clicking the “get directions” link the map returned doesn’t have an address pin. You can see that code stops and doesn’t add the additional coordinates need to place the pin.
    Code:
    <a class="open-on-google-maps" target="_blank" href="http://maps.google.com/?q=">Open on Google Maps <i class="fa fa-map-marker"></i></a>

    Now the strange part – a near duplicate site the “get directions” returns fine.

    This is an awesome plugin and I appreciate any help you have to offer regarding this.

    I too am getting only Sydney Australia as the map location. Although in the back end the location is accurate. Has anybody solved this issues yet?

    mottafx

    (@mottafx)

    Im getting only Sydney Australia as a map location and “Enter an address” field dosen’t work. Has anybody solved this issues yet?

    pmcreations

    (@pmcreations)

    This issue has NOT been solved. NO support here. Super frustrating…
    @g5theme – Can you respond?

    tarzan61

    (@tarzan61)

    The issue has not been solved and will NEVER be solved. The G5 people sold the theme to Envato. Now you must purchase the theme to get support.

    Good Luck!

    Plugin Author g5theme

    (@g5theme)

    @mottafx I think you got this bug (please press f12 for check with google chrome):
    “Geocoding Service: This API project is not authorized to use this API. For more information on authentication and Google Maps JavaScript API services please see: https://developers.google.com/maps/documentation/javascript/get-api-key&#8221;
    If you got that error, please change your Google Map API Key. Thanks

    • This reply was modified 1 year ago by g5theme.

    I am also facing the same issue

    I no longer use the G5 theme as stated above they sold the theme to Envato. I also believe this has something to do with Google now charging to add map access.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Google Maps Issue on creating a property’ is closed to new replies.