Support » Plugin: Popup Maker - Popup Forms, Optins & More » Google Map with WP Store Locator

  • Resolved Zmokin



    I have the WP Store Locator displaying in a popup that is called from a menu item called “Signing Locations” as well as from a button further down the page. However, I’m having the issue with the google map not showing up. I’ve tried different coding as suggested in your other posts but just can’t get it to work.

    In a reply from the WP Store Locator support, they said:

    There’s a fix included in the WP Store Locator code to fix this, but it does require the href value of tab to have a specific anchor.

    If you set it to ‘wpsl-map-tab’ ( <a href="wpsl-map-tab">Click</a> ), then the code to fix it runs automatically. If the href has a different value, then you can use the wpsl_map_tab_anchor filter to set a custom value.

    I’ve made the changes (or thought I did) but still not working so I’m hoping that between the two support forums, I can get this figured out.

    This is my response to their reply:

    I have a menu item called “Signing Locations” that is set to trigger the popup. When I set the url of menu item to “wpsl-map-tab” WP sets it to “http://wpsl-map-tab”. When I click on the menu item, the popup works and displays the locator but the map is still not there.

    So I changed the menu url to “#Locator” as seen in the following screenshot:
    Menu setting

    and added the following to my functions.php:

    add_filter( 'wpsl_map_tab_anchor', 'custom_map_tab_anchor' );
    function custom_map_tab_anchor() {
        return '#Locator';

    This is what shows up for the link when I inspect the code:
    <li id="menu-item-274" class="popmake-269 menu-item menu-item-type-custom menu-item-object-custom menu-item-274 pum-trigger" style="cursor: pointer;"><a href="#Locator">Signing Locations</a></li>

    The href seems to be correct but I still can’t get it to work.

    I’m hoping by posting that information here, you might have an idea of what they are talking about and possibly know what I need to do.

    Thanks for your time.

    • This topic was modified 1 year, 9 months ago by  Zmokin.
    • This topic was modified 1 year, 9 months ago by  Zmokin.
    • This topic was modified 1 year, 9 months ago by  Zmokin.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support yogaman5020


    Hello @zmokin:

    You’ve got a popup named ‘Store Locator’ (ID: popmake-269) which is linked to the nav element labeled ‘Signing Locations’ at the top of your front page. When I inspect your code, the link source for ‘Store Locator’ is <a href="#None">. If you’re using a caching plugin on your site, either temporarily deactivate it, or flush the cache. Otherwise, change the href to what you want.

    As for the Google Maps not appearing, we have a support article in our documentation that might be of use to you in addressing your problem.

    If the documentation does not address your issue, one other thing I notice about the Google Maps is that the z-index values for the map seem incredibly low (1,2,3,… etc). You might need to change those up (I would test first in the browser)

    Here’s a link that further explains ‘z-index’ in CSS:

    Bear in mind that the z-index value for a popup container by default is set to 1999999999 in the Popup Admin (‘Display Settings’ >> ‘Z-index’). You may need to set a z-index value for your map that exceeds that value in order for it to appear in front of the popup.

    • This reply was modified 1 year, 9 months ago by  yogaman5020.
    Plugin Support yogaman5020


    Hello @zmokin:

    I just responded back to you and another fellow in the following forum post.

    It includes the same link to the support article above. Did you consult the article? Was it useful?

    • This reply was modified 1 year, 9 months ago by  yogaman5020.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Google Map with WP Store Locator’ is closed to new replies.