Support » Plugin: Events Manager » Google Map – Location Not Found

  • This was all working since installed in April, but around 6 days ago (10 October) I lost the function to add any new maps. I add locations at least weekly and the problem just came up last week and I was not installing any plugins for a while now.

    But to troubleshoot, I have deactivated all plugins except Events Manager.
    I went to my Google Cloud account and copied the API key into the EM Map settings, though it was the same key as before. While there I looked for any messages from Google about problems with my account – everything looks OK.

    None of this is making an difference. So I have about 10 new locations with no maps. Pre-existing locations are not affected. Google support docs don’t offer any direction.

    Events Manager v5.9.6

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’ve got the same issue, except it isn’t working anywhere. API key is copied correctly, and no problems to be found on Google Cloud account. Even with Accept requests from these HTTP referrers (web sites) left blank it doesn’t work.

    I’ve checked every setting in Event manager and followed the guides to setting up Google Maps API, and unfortunatly nothing works.

    I am seeing this and have been trying to troubleshoot it for the past 2 weeks.

    Patrick

    (@duisterdenhaag)

    If you want something that does work:
    https://wordpress.org/plugins/stonehenge-em-osm/ 😀

    Hi Patrick. I tried OSM the first month I was setting up my site but went with Google because of familiarity for me and visitors.

    I will submit any of my additional questions over to the OSM plugin.
    Mostly what “work” is involved for the over 240 locations I already have.

    Charlie

    One puzzle to me is that I have been seeing numerous referrals to “Dynamic Maps API” or “Dynamic” in the case of Events Manager Settings > Google Map Type.

    There are many articles as recent as September 2019 mentioning Dynamic Maps API and one even showing it on a screen capture from the Google Cloud web page of available Map APIs, but it is not to be found on Google Cloud now. Not even with a site wide word search.

    I don’t know much at all about scripts but here is what I get in the Console when I try to create a new location’s address or change any part of an existing location address. For example if I change the street number or the city and hit my tab key, this comes up on the console in red:

    events-manager.js?ver=5.96:1032 Uncaught TypeError: $ is not a function
    at HTMLInputElement.<anonymous> (events-manager.js?ver=5.96:1032)
    at HTMLInputElement.dispatch (load-scripts.php?c=0…lupload&ver=5.0.7:3)
    at HTMLInputElement.r.handle (load-scripts.php?c=0…lupload&ver=5.0.7:3)

    CharlieAR

    (@charliear)

    An update at least on my site, regarding Google Maps.
    The ability to create a new location has returned BUT only when I use the front end form Submit Event. Not on the back end Add Event or Add Location.

    Hopefully that is a clue on what could be investigated by anyone that can decipher PHP and compare the code those different methods involve for maps.

    I don’t think it’s anything I changed. My last contact over a week ago with Google Cloud support was that I have all the APIs required and I’m correct with my settings. My Google Cloud account is active and in good order, etc.

    Plugin Author Marcus

    (@netweblogic)

    Hello, sorry for the delayed reply here.

    I think this is a bug that got introduced by mistake somehow. We’ll be updating a fix in the coming days hopefully, but if you’d like to sort this out quickly here’s the solution:

    In file events-manager/includes/js/events-manager.js line 1032 replace this:

    if( $(this).prop('readonly') === true ) return;

    with this

    if( jQuery(this).prop('readonly') === true ) return;

    Hello, just to let you know this has been fixed in the recent update.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.