WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Google Language Translator plugin stopped working.

[Resolved] Google Language Translator plugin stopped working.

  • Hi, we’ve been using the Google Language Translator plugin for a while without issues, it has stopped working. I assume it stopped after we upgraded to WP 3.8, but not sure as we just noticed it missing. We have the lastest version 3.0 installed. The shortcode is working as I can see all the scripts and HTML, but the div that should contain the form is empty:
    <div id="google_language_translator"></div>

    Any idea what could be the issue with this? BTW, it shows up fine in the admin under “preview”, if that helps.

    Here’s the site.

    http://wordpress.org/plugins/google-language-translator/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Figured it out, conflict with the Landing Pages plugin.

    Hey Pixelwind,

    What conflict/error message did you see?

    Didn’t see any error message, just stopped working. I noticed it was working on one of our pages and used the Plugin Organizer plugin to see what plugins were disabled on that page. Turned out that it was the Landing Pages Plugin. I disabled it globally and enabled only on the page that needed that plugin (which I thought I had already done) and all was working properly after that.

    I just did a quick test to see if there are any errors, only saw 1, not sure it’s related, though: Uncaught TypeError: Object 36 has no method ‘replace’

    There’s some stuff about the online chat feature we have, could be related to that.

    Before I figured out what was wrong, I tried using the Google code for translation without the plugin and had the same conflict.

    Interesting. So it was a javascript conflict and not a PHP conflict?

    We just pushed a new version of landing pages (2 minutes ago) perhaps it might solve the issue

    Not sure, that’s all that showed up in the inspector. I upgraded your plugin and reactivated it on this page if you want to have a look. The translation dropdown should be to the left the social icons. You can see that on any other page, for reference. Let me know when you’re done looking so I can switch it back.

    Plugin Author Rob Myrick
    Participant

    @rm2773

    Hi guys, are there still any issues here? Pixelwind, looking good here! Let me know if you guys have any questions….I’ll help if needed.

    Thanks, Rob

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Google Language Translator plugin stopped working.’ is closed to new replies.