Support » Plugin: Google XML Sitemap Generator » Google keeps saying sitemap is HTML

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author XmlSitemapGenerator

    (@xmlsitemapgenerator)

    Hello.

    the first thing to check is that you are using the correct URL. Our plugin produces a number of pages.

    The one you need is :
    /xmlsitemap.xml

    If this is returning HTML then there is probably a problem with your install or a conflict with another plugin. It may also be a bug.

    Could you let me know your website address so I can take a look at your sitemap please?

    it is keywestfloridakeysconcierge.com.

    Plugin Author XmlSitemapGenerator

    (@xmlsitemapgenerator)

    Ok, there is definitely something strange going on.

    When I navigate to : http://keywestfloridakeysconcierge.com/xmlsitemap.xml

    I would expect to see our sitemap , but I see your about us page, which is why google is telling you it is an HTML page.

    The first thing worth a try is deactivating and reactivating the plugin to in case it didn’t register properly.

    There may also be a conflict with another plugin. You may be able to tell this by selectively deactivating other plugins, in particular anything that might interfere with custom urls, webpages, redirects, etc.

    I deactivated it and reactivated it and the problem is still there. I deactivated Contact Form 7 (contact plugin) and it still went to the homepage.

    Plugin Author XmlSitemapGenerator

    (@xmlsitemapgenerator)

    Okay thanks.

    Is that the only plugin you are using?

    What is your permalink setting (Plain, etc.)
    menu > settings > permalinks

    Did you install via network / multi-site admin?

    Permalink setting is plain and I inherited this from someone else so I am not sure how they set it up.

    Plugin Author XmlSitemapGenerator

    (@xmlsitemapgenerator)

    Thanks.

    So it could be a few things but most likely there is a problem with url rewriting on your setup.

    Rewriting enables our plugin to register a custom url so you get a friendly
    /XmlSitemap.Xml address.

    It may be that they are not enabled on your system or it is not working properly with our plugin.

    If your wordpress blog works in any mode other than “plain” then it suggests that url rewriting is working. If it doesn’t then this confirms the problem.

    This is outside the scope of what I can support and I would advise caution if you are not experienced in this area. Such settings have the potential to damage your website/blog if not configured correctly, including damaging your SEO / SEPR.

    If you can confirm that permalinks / url rewriting does work then I can investigate further.

    Plugin Author XmlSitemapGenerator

    (@xmlsitemapgenerator)

    Hi, as we haven’t heard from you and haven’t been able to replicate the issue, I’m going to close this issue. If you need any further help please let me know.

    Thanks

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Google keeps saying sitemap is HTML’ is closed to new replies.