Support » Plugin: Yoast SEO » Google is indexing my media file URL’s!

  • Resolved Barn2Plugins

    (@barn2media)


    Hi, there’s a major problem with my Yoast SEO setup where the direct links to media files (e.g. jpegs) are showing up in Google, which I didn’t even know was possible.

    For example, if you Google ‘e-book plugins barn2’ then the first result takes you directly to a JPG image – not the attachment page, the actual image file.

    How can I stop this please?

    Thank you

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Jerlyn

    (@jerparx)

    You can set Show Media in search results? to NO if you don’t want your media indexed by Google.

    See guide here: https://imgur.com/a/u4nmQyJ

    Thanks, I previously tried that and Google continued indexing my media attachments – this was over a month ago. I then selected the option to ‘Redirect attachment URLs to the attachment itself?’ and the actual media files are now appearing in the Google results. That was weeks ago and Google will have crawled my site since then, so I don’t understand why the media files are still being indexed in the normal search results. Surely they should only appear in the image results!

    Is there another way I can fix this please?

    Thank you

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Unfortunately, there is no other way in order to remove the media files from the Google search results except the media attachment redirect option.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Google is indexing my media file URL’s!’ is closed to new replies.