Support » Plugin: Rank Math SEO » Google Indexing API says that most of my pages are unindexed

  • Resolved matrixpoland

    (@matrixpoland)


    Hi. I’m using google indexing API and when i choose “get status” from most of my pages i get this messege

    “code”: 404,
    “body”: {
    “error”: {
    “code”: 404,
    “message”: “Requested entity was not found.”,
    “status”: “NOT_FOUND”
    }

    How fix that or how to update entities for all pages? I don’t want to index all pages manually

    My pages are not indexed in a good way.

    Google doesn’t see description in right way. Maybe even more problems.

    • This topic was modified 1 year, 10 months ago by matrixpoland.
    • This topic was modified 1 year, 10 months ago by matrixpoland.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Rank Math

    (@rankmath)

    Hello @matrixpoland,

    Thank you for contacting the support and sorry for any inconvenience that might have been caused due to that.

    Please check the reason and the solution for the issue you are facing:
    https://i.rankmath.com/9hsLGa
    https://rankmath.com/blog/google-indexing-api/

    Also, please stay advised that the plugin should only be used on websites where JobPosting or LiveStreaming is used, as stated in the article.

    Please note that it is completely normal for a newly published post/page/website to take time before it gets crawled or indexed by Google. It depends on a lot of factors. Your posting frequency + the domain authority are just two of the many factors Google considers when indexing some new URL. Google assigns a crawl budget to your website depending on these factors (especially these two) and that has a direct effect on how soon or how late your content can get indexed.

    You can also check for noindex tag here to rule out that your page isn’t getting indexed due to a mistake in plugin settings:
    https://smallseotools.com/meta-tags-analyzer/

    If noindex is not present, then it is just a waiting game before Google decides to include the URL in the index. No SEO plugin can force Google to index something they don’t want to.

    With that said, we have found that barring any issues like copied/DMCA/low-quality content issues – Google usually indexes posts within a week or two. So, we request you to kindly wait.

    Google even says that on their official website:
    https://i.rankmath.com/QB4Dhl

    The above screenshot was taken from this page:
    https://support.google.com/webmasters/answer/7552505#missing-jobs

    So, you have to be a bit patient and allow it some time. If your website isn’t indexed even after a week, you can place a manual indexing request here:
    https://support.google.com/webmasters/answer/9012289

    Finally, it all boils down to the quality of the content, and if your content improves Google’s overall search index.

    Please check this article where one of the Google employees mentioned:
    “If your site relies on manual index submission for normal content, you need to significantly improve your site. Search console does not fix your site, you need to do that yourself.” – JohnMu
    https://www.seroundtable.com/google-manually-index-site-quality-28942.html

    With that said, here’s a good article on how to ensure that your website gets indexed regularly:
    https://ahrefs.com/blog/google-index/

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    Thread Starter matrixpoland

    (@matrixpoland)

    “Please note that it is completely normal for a newly published post/page/website to take time before it gets crawled or indexed by Google.”

    My posts with erros are from 1-2 years ago, not weeks or days…

    I will check rest of the tips later

    Plugin Author Rank Math

    (@rankmath)

    Hello @matrixpoland

    Sure.

    For the Meta Description:
    1. First of all, I am assuming that you have already changed the SEO Meta Title and Meta Description with the help of Rank Math:

    Add a Meta Description in Classic Editor: https://i.rankmath.com/dhECkg
    Add title and description in Gutenberg: https://i.rankmath.com/ZO21Cd

    2. Then, ensure that this is the setting in the Schema tab if the Schema Markup module is enabled on your website:
    https://i.rankmath.com/pG0pcS

    To reiterate, the Schema title must show %seo_title% and the description should show %seo_description% – this will ensure your SEO title and SEO Description that you set up via Rank Math can also be used for your schema details:

    3. The next step is to check if your title/description is properly set up in the page source:
    https://i.rankmath.com/HwXR1o

    You can use this tool for the same as well: https://www.heymeta.com/

    4. If it matches your settings, then you must check if Google has seen the changes already or not.

    For that, please check when the Google cache was updated for that page:
    a. https://i.rankmath.com/9q6X0H
    b. https://i.rankmath.com/R8N0Uh

    If the cache date is from before adding the new meta description, then you just have to wait for Google to re-crawl and re-index the page with the new info. If the date is after you made the changes, then you just have to wait it out and there is no further input needed from your end.

    Do note that if everything’s fine and Google still decides to show a different meta title/description for your search keyword, there is nothing you can do as Google sometimes ignores the custom meta info altogether and show something from the page’s content that matches the search intent better.

    Here are some of the common reasons Google might not use the meta description you provided:
    – The meta description is not relevant or useful (ie, just a collection of keywords).
    – The exact same meta description is provided across a large number of pages.
    – The meta description doesn’t match what the user is searching for, but other content on the page does.

    There is a whole article dedicated to this on SearchEngineJournal:
    https://www.searchenginejournal.com/google-offers-suggestions-for-avoiding-meta-description-rewrites/359884/

    Here is an example showing Google changes title depending on the keyword used:
    https://i.rankmath.com/oT6VQe
    &
    https://i.rankmath.com/Mrhb0x

    The best you can do is optimize your meta tags to try and match the intent of the search/keyword.

    Hope that helps. If you have any further question(s), please let us know. Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Google Indexing API says that most of my pages are unindexed’ is closed to new replies.