Support » Plugin: Email Encoder - Protect Email Address » Google index shows encoded info

  • I am using the plugin for email and phone number. The info shows as “successfully encoded”. Also, I cannot see the encoded text in the page source.

    However, if I search for my email or phone number on Google, my webpage shows in the search results.

    How can I prevent the Googlebot from decoding and indexing my encoded email and phone number?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Ironikus

    (@ironikus)

    Hey @morecowbellll
    thanks a lot for your message!
    Have you made sure that Google has already crawled your new page after activating the email protection?
    Thanks already a lot!

    I have cleared the cache and had the page re-indexed several times. Also, I have been using the plugin since the first publication of the website, so there wouldn’t have been any unencoded info ever available for Google to index.

    Plugin Author Ironikus

    (@ironikus)

    Hi @morecowbellll – Sorry for the late answer! I checked a bit more on that topic and I believe that google always renders the page before indexing it. What I would recommend you to do is to include the phone number within a picture or in a way that Google can’t read it by default. The other option you have is to limit Google from indexing the whole page where you have mentioned the phone number.
    To do that, you can either create a robots.txt file and edit it depending on the pages where you have included the email or by setting a meta tag. You can find more information about that here: https://michaelsoolee.com/prevent-google-index/
    Hope this helps!
    In case you have more questions, feel free to reach out at any time! 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.