WordPress.org

Ready to get started?Download WordPress

Forums

Google image search/page not found (3 posts)

  1. mrerikmt
    Member
    Posted 2 years ago #

    I am working on a photography site that is using NextGen gallery. The problem is that when an image from this site is located in Google Image Search, and then that image is clicked on, the page that you are directed to is "whoops page not found" rather than to the gallery/page that the image resides on.

    So far I can't find any info on why this is happening. Could it be a NextGen setting? I think I set it up properly. Permalink issue?

    Thanks for any help.

    http://www.patrickclaytonphotography.com

  2. I would install the broken link checker plugin and make sure that all your links are ok.
    If all the images show up properly on your site, I wouldn't worry too much about it.
    Google could have indexed some of your previous images which have now been deleted. If it's a Google issue, then I'm not sure what can be done about it.

    Perhaps Google needs a bit more time to crawl and index your site.

  3. mrerikmt
    Member
    Posted 2 years ago #

    Thanks for responding. I will try out the link checker. I suspect it may have something to do with Google not having crawled the site recently. It's a new site with a URL from an old site so I might just have to wait. I keep reading that Google images and NGG don't get along well. Even if you have site maps properly submitted, there can be problems.

    I am interested in pursuing all possibilites on this so if anyone else out there has any ideas I would love to hear them.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic