WordPress.org

Forums

BigContact Contact Page
Google has disabled use of Maps API for this application. (6 posts)

  1. chaddcarr
    Member
    Posted 1 year ago #

    The map was working fine. However, recently the following error message pops up and only the address associated with the API key appears where the map used to be. If I click on that address (it's a hyperlink), I am taken to Google maps where the address icon appears on the map.

    Any ideas?

    http://www.kaitannasolar.com/solar/contacts/

    https://wordpress.org/plugins/bigcontact/

  2. chaddcarr
    Member
    Posted 1 year ago #

    Sorry, the error message is:

    Google has disabled use of Maps API for this application. See the Terms of Service for more information: Http://www.google.com/intl/en-US_US/help/terms_maps.html

  3. creatorsdream
    Member
    Posted 1 year ago #

    Yea, I'm getting the same error. I wonder if it has to do with Java? Here's the error I'm receiving...

    Google has disabled use of the Maps API for this application. The provided key is not a valid Google API Key, or it is not authorized for the Google Maps Javascript API v3 on this site. If you are the owner of this application, you can learn about obtaining a valid key here: https://developers.google.com/maps/documentation/javascript/tutorial#api_key

    http://smalltowncoffeeroasters.com/contact/

  4. creatorsdream
    Member
    Posted 1 year ago #

    Okay, I was able to fix the error by adding ONLY the contacts page in the Referers: section. The google maps now works and no errors.

  5. NorikDavtian
    Member
    Plugin Author

    Posted 1 year ago #

    Soon we are going to release another update that's not going to require Google maps API anymore.
    However, you might be using your API key on a site that's not authorized so. You need to check your Google API dashboard to see what's conflicting.

    Also as you mentioned here, there is a link for the error, check that.

  6. ElBee
    Member
    Posted 11 months ago #

    I am now having the same issue as creatorsdream but am not sure how to fix it. Also having an issue with the home page slide show. Both items just started to happen and I am stumped. Consider me an ultimate novice in this area. Help for either would be greatly appreciated.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • BigContact Contact Page
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags