Support » Plugin: SSL Insecure Content Fixer » Google fonts the culprit but where is it loading

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author webaware

    (@webaware)

    G’day groggy72,

    Nivo Slider and Revolution Slider are the Google Fonts culprits:

    http://www.healthylegs.com.au/wp-content/plugins/1497329V3/assets/js/nivo-slider/nivo-slider.css
    http://www.healthylegs.com.au/wp-content/plugins/revslider/rs-plugin/css/captions.css

    However, I notice that you have WooCommerce installed and are currently getting lots of errors with scripts and stylesheets loading over HTTP instead of HTTPS. WooCommerce should be fixing that, you shouldn’t need my plugin, so something weird is happening there.

    groggy72

    (@groggy72)

    G’day Ross

    Thanks for taking the time to look at my query. I guess its going to be heartbreaking to figure this one out.

    Thanks mate

    Plugin Author webaware

    (@webaware)

    Do you have my plugin activated? If so, turn it off and see if WooCommerce is correctly handling scripts and stylesheets. You can see what’s causing SSL blocked content errors by opening the developer console in Google Chrome, or Firebug in Firefox.

    groggy72

    (@groggy72)

    Hey Ross – Ok just did that – just knocked of your plugin and the only things blocked by chrome are the google fonts you mentioned above and the logo on the page (but i’m guessing your plugin would fix this).

    The only other error on the page according to chrome is this

    event.returnValue is deprecated. Please use the standard event.preventDefault() instead.

    Plugin Author webaware

    (@webaware)

    G’day groggy,

    No plugin will fix those, you need to edit the CSS files and change the http to https, then tell the plugin authors to fix their CSS. 🙂

    cheers,
    Ross

    groggy72

    (@groggy72)

    er ok, thanks.

    groggy72

    (@groggy72)

    Hi Ross – last question I promise

    I reckon I can sort out all the other problems but I would be most grateful if you could tell me how I can make the logo – which is loading over http:// load to https://

    groggy72

    (@groggy72)

    its ok, all fixed up – thanks for your help.

    Plugin Author webaware

    (@webaware)

    Excellent, was it just a setting in your theme options? Good to hear it’s all sorted out.

    cheers,
    Ross

    groggy72

    (@groggy72)

    Hi Ross. I’m running a plugin called better WP security which has an option to force secure pages built into it. It fixed the non secure url of the logo but I still have issues with Google fonts even though the page says they are https: and I have no plugins loading on the page.

    I have torn clumps of my hair out. Now any spray on hair products?

    groggy72

    (@groggy72)

    I’m guessing its the two culprits you already specified

    http://www.healthylegs.com.au/wp-content/plugins/1497329V3/assets/js/nivo-slider/nivo-slider.css
    http://www.healthylegs.com.au/wp-content/plugins/revslider/rs-plugin/css/captions.css

    I’m gathering these still load on the page even though they are not visible

    Plugin Author webaware

    (@webaware)

    Yes, you need to edit those two CSS files. Then tell the plugin authors!

    groggy72

    (@groggy72)

    Sorted! Thanks so much Ross. You have been most helpful.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Google fonts the culprit but where is it loading’ is closed to new replies.