WordPress.org

Forums

Ultimate Coming Soon Page
[resolved] Google fonts aren't rendering in custom CSS (8 posts)

  1. Sarah Cauble
    Member
    Posted 1 year ago #

    I'm using custom CSS to style headings and paragraphs and I am trying to use Google fonts, but they're only rendering on my computer because I have the fonts installed. It doesn't render on any other machine. Any idea on how to resolve? I'm using the plugin on http://www.sarahcauble.com

    https://wordpress.org/plugins/ultimate-coming-soon-page/

  2. John Turner
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Sarah,

    Looks like there is an error including one of the fonts as you can see in this screenshot.

    http://www.screencast.com/t/PVzvkksrv6FJ

    What is the second font suppose to be? You can manually include it and I'll add a bug report.

    Thanks

  3. Sarah Cauble
    Member
    Posted 1 year ago #

    Hi John,

    Hmm... I'm not sure where that script with the errors is located - could it be embedded in the Headway theme I'm using? Because I didn't add that one.

    I did manually add the IM Fell English font but it still isn't rendering. I'll try to add the second font as well - it's called Montserrat.

    Looks like adding both still didn't resolve the issue.

  4. Sarah Cauble
    Member
    Posted 1 year ago #

    I realized what was causing the error you found - it was because I didn't have a font selected in the options for Headline Font. But the reason I didn't select something in the first place is because when I choose "IM Fell English," it's styling it with faux italics, not the font's italic style.

  5. John Turner
    Member
    Plugin Author

    Posted 1 year ago #

    OK, yeah we only include the base font. If you want any variation just include the link Google provides.

  6. Sarah Cauble
    Member
    Posted 1 year ago #

    Then shouldn't the Montserrat font at least be rendering? I'm not using an alternative weight or style. It's like I said initially, font's styled in the custom CSS don't render (at least for me). I've already included all of the links Google provides.

  7. John Turner
    Member
    Plugin Author

    Posted 1 year ago #

    I see you import statement but for some reason it not being included. This is the only one I see. http://www.screencast.com/t/HdmLplN5Mu

  8. Sarah Cauble
    Member
    Posted 1 year ago #

    Maybe it's the only one you see because it's the only one I've selected in the plugin options? So maybe that's why the italic style and Montserrat font aren't rendering even though the import statements are there?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Ultimate Coming Soon Page
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic