WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Google Fonts

[Resolved] Google Fonts

  • My website downloads over 300 google fonts every time a page loads. I don’t use these fonts, but it taks almost 1.4 seconds for all these fonts to load. I have scoured my css files and cannot find anywhere that it is elling the website to download these fonts. I have tried changing my theme, same story. I tried getting rid of a bunch of plug-ins, same story. Anyone have any ideas about how I can identify this problems source.

    Suggestions would be VERY appreciated. The website is shenzhenapartmentrental.com

Viewing 5 replies - 1 through 5 (of 5 total)
  • catacaustic

    @catacaustic

    very awesome

    Looking at your home pages code, I’d guess that this would be the issue:

    <!-- fonts delivered by WordPress Google Fonts, a plugin by Adrian3.com -->

    You’d need to check the settings in that plugin to see just what it’s loading.

    If that doesn’t work, disable all (yes, all) plugins and switch back to the default theme. Check there that you aren’t haveing the same problem (if you do then there’s something else wrong with yor system). From there, re-enable the theme and the plugins one-by-one and check each time until you find out whcih one is causing that extra load.

    Catacaustic. Thanks. Tried that. even deleted y home page, deleted the posts that showed up in it. nope! Still loading those fonts! I have no idea where the site is getting the command to load all those fonts from, but it only affects the home page. All other pages do not have that issue it seems!
    If anyone can tell me the sequence that WordPress goes through to load a home page, I would appreciate it, because somewhere in that sequence must lie that command!

    catacaustic

    @catacaustic

    very awesome

    Found it;

    <link rel='stylesheet' id='myStyleSheets-css' href='http://www.shenzhenapartmentrental.com/wp-content/plugins/simple-tinymce-button-upgrade/josh-font-style.css?ver=3.5.1' type='text/css' media='all' />

    That file reads…

    @charset "utf-8";
    
    /* CSS Document */
    
    @import url(http://fonts.googleapis.com/css?family=Questrial);
    @import url(http://fonts.googleapis.com/css?family=Astloch);
    @import url(http://fonts.googleapis.com/css?family=IM+Fell+English+SC);
    @import url(http://fonts.googleapis.com/css?family=Lekton);
    @import url(http://fonts.googleapis.com/css?family=Nova+Round);
    ...

    There’s a bit over 290 Google fonts being loaded by that one CSS file.

    You obviously didn’t disable all of the plugins like I said, or you’d have seen that this one was the culprit. 😉 Disable that plugin and you should have no more problems.

    ah man! You are a lifesaver! Thanks so much! Funny thing is tat when I deactivated it, it still carried on pulling those fonts. I had to actually delete the plugin before it stopped!

    🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Google Fonts’ is closed to new replies.