Support » Plugin: WordPress Social Invitations - Lite » Google Error 400 – redirect_uri_mismatch

  • wci

    (@wci)


    Hi support team,

    all other submissions are working proper, but using your google setup guide, activating within google api console and trying to use google+ then an error 400 is displayed. Find here a screen shot.

    I tried it now 5 times times with same error result, even by using just the uri url and browser incognito mode. Within google api console I also have authenticated the domain with TXT record to ensure that it shall work.

    Still bad result: “User profile request failed. Most likely the user is not connected to the provider and he should to authenticate again”.

    Does this has to do with https approach or cpanel or firewall settings. Within plugin the URL’s and URI’s are setup proper (see in screen shot)?

    Looking forward to your advice, Alex

    • This topic was modified 3 years ago by  wci.
Viewing 4 replies - 1 through 4 (of 4 total)
  • h4m1dreza

    (@h4m1dreza)

    Same Issue.

    Same here – did step by step and tripple checked everything.

    Getting:

    400. That’s an error.

    Error: redirect_uri_mismatch

    The redirect URI in the request,<our_domain>/wp-content/plugins/wp-social-invitations/hybridauth/hybridauth/?hauth.done=Google, does not match the ones authorized for the OAuth client. Visit https://console.developers.google.com/apis/credentials/oauthclient/57958096081-b8m1prju254gbdknulv5c0diugke2ge9.apps.googleusercontent.com?project=57958096081 to update the authorized redirect URIs.

    Any ideas?

    • This reply was modified 2 years, 11 months ago by  yositsitsu.

    LOL after I posted it here had an idea to compare between the url that google complains about:
    /wp-content/plugins/wp-social-invitations/hybridauth/hybridauth/?hauth.done=Google

    to what the documentation says should be saved under “Authorized redirect URI”
    /wp-content/plugins/wordpress-social-invitations/hybridauth/hybridauth/?hauth.done=Google

    Get it now :)))

    “wordpress-social-invitations” was changed to “wp-social-invitations”

    Step 3 should be:
    On “Authorized redirect URI” enter your website url followed by /wp-content/plugins/wp-social-invitations/hybridauth/hybridauth/?hauth.done=Google

    Now on to the next step!
    Thanks 😉

    Hi yositsitsu,

    GREAT YOUT FOUND OUT THE ISSUE TO SOLVE MINE !

    Many thanks and I hope that the wp social invite developers will adjust their documentation as fast as possible.

    Best regards, Alex

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Google Error 400 – redirect_uri_mismatch’ is closed to new replies.