Support » Plugin: UpdraftPlus WordPress Backup Plugin » Google Drive redirect_uri_mismatch

  • Resolved laptopleon

    (@laptopleon)



    I’ve been trying to get updraftPlus to copy to Google Drive, for two hours and am now having aggressive feelings. Feel like breaking a window by throwing a clunky desktop trough it.

    But seriously. I know you (David) have no control over Google’s methods, but it would be ever so helpful if there was an up to date, step by step manual. I would make it myself if I know what I was doing.

    When trying to authorize for Google Drive, I’m stuck at the error report redirect_uri_mismatch. I created a project and login credentials and even checked that the site is added to Google Search Console.

    You’ll probably say I should take this on with Google and vice versa.

    I at least wanted to let you know of this problem though.

    • This topic was modified 2 years ago by  laptopleon. Reason: keywords had no comma
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author David Anderson

    (@davidanderson)

    Hi,

    Google “updraftplus redirect_uri_mismatch” – the first result should be the relevant FAQ.

    David

    laptopleon

    (@laptopleon)

    It’s even better, the error report pane has links in it:

    The redirect URI in the request, http://campingdelagewerf.nl/wpdivi/wp-admin/options-general.php?action=updraftmethod-googledrive-auth, does not match the ones authorized for the OAuth client. Visit https://console.developers.google.com/apis/credentials/oauthclient/677738701724-ktq9r8gliem0on97772rkho2s89n57u6.apps.googleusercontent.com?project=677738701724 to update the authorized redirect URIs.

    However, I can’t find anything that I’m missing.

    Should I add something at “Authorised redirect URIs”? If so, can you give an example? Should it be “http://campingdelagewerf.nl/oauthsomething”?

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    In your Google Project’s OAuth 2.0 credentials, there should be a field labelled ‘Authorised redirect URIs’ (or similar).
    You need to enter the URL shown in the Google Drive remote storage settings in this field:
    http://campingdelagewerf.nl/wpdivi/wp-admin/options-general.php?action=updraftmethod-googledrive-auth

    laptopleon

    (@laptopleon)

    That did it!

    Thank you!

    (Then I saw it was staring me in the face all along. Embarrassing silence)

    Plugin Author David Anderson

    (@davidanderson)

    You’re welcome!

    If you find UpdraftPlus useful, then please give us a positive review, here: https://wordpress.org/support/view/plugin-reviews/updraftplus?rate=5#postform

    (If we’re not yet worth 5 stars, then please don’t review, but instead reply here to let us know why not – reviews less than 5 stars bring our average down!).

    Best wishes,
    David

    laptopleon

    (@laptopleon)

    I definitely think it’s worth 5 stars and will give a positive review.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Google Drive redirect_uri_mismatch’ is closed to new replies.