Support » Plugin: External Media » Google Drive not loading images

  • Resolved Don Betts

    (@dbetts)


    I’ve connected to my Google Drive, but when I import images into the Media Library they are not imported as image files, but documents. The Media Library lists the file type as application/jsoncharsetUTF-8

    When I insert into a post it only inserts a url that shows nothing.

    FYI, I set up my credentials as a web client so I could put in my sites url as the Authorized JavaScript origins, otherwise I got a no registered origin error.

    https://wordpress.org/plugins/external-media/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author minnur

    (@minnur)

    No registered origin probably happens because of missing your WP domain from the domains list. Make sure you add Redirect URL from the plugin settings page to your Google client.

    I’m having this same issue. Seems to connect to google drive ok, thumbnails show up, does what appears to be an import, but the file just shows up as a application/jsoncharsetUTF-8.

    Does not appear to download the image.

    Plugin Author minnur

    (@minnur)

    Sounds like Drive API is not enabled, could you verify that ?

    yes, that was it. I was not aware that the Drive API had to be enabled for all projects individually. I had it on for another project, but not this one šŸ™‚

    Thanks.

    Plugin Author minnur

    (@minnur)

    Glad you solved this issue. Marking as resolved.

    HI, Where do you add the Redirect URL from the plugin settings to?

    Can’t see where to put this!

    Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Google Drive not loading images’ is closed to new replies.